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SYMANTEC LICENSE AND WARRANTY
The software which accompanies this license (the "Software") is the 
property of Symantec or its licensors and is protected by copyright 
law. While Symantec continues to own the Software, you will have 
certain rights to use the Software after your acceptance of this li-
cense. Except as may be modified by a license addendum which 
accompanies this license, your rights and obligations with respect 
to the use of this Software are as follows: 

• You may: 

(i) use one copy of the Software on a single computer; 

(ii) make one copy of the Software for archival purposes, or 
copy the software onto the hard disk of your computer and retain 
the original for archival purposes;

(iii) use the Software on a network, provided that you have a 
licensed copy of the Software for each computer that can access the 
Software over that network;  

(iv) after written notice to Symantec, transfer the Software on 
a permanent basis to another person or entity, provided that you 
retain no copies of the Software and the transferee agrees to the 
terms of this agreement; and 

(v) if a single person uses the computer on which the Soft-
ware is installed at least 80% of the time, then after returning the 
completed product registration card which accompanies the Soft-
ware, that person may also use the Software on a single home com-
puter.  

• You may not:

(i) copy the documentation which accompanies the Software;

(ii) sublicense, rent or lease any portion of the Software;

(iii) reverse engineer, decompile, disassemble, modify, trans-
late, make any attempt to discover the source code of the Software, 
or create derivative works from the Software; or

(iv) use a previous version or copy of the Software after you 
have received a disk replacement set or an upgraded version as a 
replacement of the prior version, unless you donate a previous ver-
sion of an upgraded version to a charity of your choice, and such 
charity agrees in writing that it will be the sole end user of the prod-
uct, and that it will abide by the terms of this agreement. Unless you 
so donate a previous version of an upgraded version, upon upgrad-
ing the Software, all copies of the prior version must be destroyed.

• Sixty Day Money Back Guarantee:

If you are the original licensee of this copy of the Software and are 
dissatisfied with it for any reason, you may return the complete 
product, together with your receipt, to Symantec or an authorized 
dealer, postage prepaid, for a full refund at any time during the sixty 
day period following the delivery to you of the Software.
• Limited Warranty:

Symantec warrants that the media on which the Software is distrib-
uted will be free from defects for a period of sixty (60) days from 
the date of delivery of the Software to you. Your sole remedy in the 
event of a breach of this warranty will be that Symantec will, at its 
option, replace any defective media returned to Symantec within 
the warranty period or refund the money you paid for the Software. 
Symantec does not warrant that the Software will meet your re-
quirements or that operation of the Software will be uninterrupted 
or that the Software will be error-free. 

THE ABOVE WARRANTY IS EXCLUSIVE AND IN LIEU OF ALL 
OTHER WARRANTIES, WHETHER EXPRESS OR IMPLIED, INCLUD-
ING THE IMPLIED WARRANTIES OF MERCHANTABILITY, FIT-
NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  
THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU 
MAY HAVE OTHER RIGHTS, WHICH VARY FROM STATE TO 
STATE.

• Disclaimer of Damages:

REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN 
FAILS OF ITS ESSENTIAL PURPOSE, IN NO EVENT WILL SYMAN-
TEC BE LIABLE TO YOU FOR ANY SPECIAL, CONSEQUENTIAL, 
INDIRECT OR SIMILAR DAMAGES, INCLUDING ANY LOST PROF-
ITS OR LOST DATA ARISING OUT OF THE USE OR INABILITY TO 
USE THE SOFTWARE EVEN IF SYMANTEC HAS BEEN ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGES.

SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION 
OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES 
SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY 
TO YOU.

IN NO CASE SHALL SYMANTEC’S LIABILITY EXCEED THE PUR-
CHASE PRICE FOR THE SOFTWARE. The disclaimers and limita-
tions set forth above will apply regardless of whether you accept 
the Software.

• U.S. Government Restricted Rights:

RESTRICTED RIGHTS LEGEND. Use, duplication, or disclosure by 
the Government is subject to restrictions as set forth in subpara-
graph (c) (1) (ii) of the Rights in Technical Data and Computer Soft-
ware clause at DFARS 252.227-7013 or subparagraphs (c) (1) and 
(2) of the Commercial Computer Software-Restricted Rights clause 
at 48 CFR 52.227-19, as applicable, Symantec Corporation, 10201 
Torre Avenue, Cupertino, CA 95014.

• General:

This Agreement will be governed by the laws of the State of Cali-
fornia. This Agreement may only be modified by a license adden-
dum which accompanies this license or by a written document 
which has been signed by both you and Symantec. Should you 
have any questions concerning this Agreement, or if you desire to 
contact Symantec for any reason, please write: 

Symantec Customer Service, 175 W. Broadway, 
Eugene, OR 97401.



 

License and Warranty Addendum

 

The software you are acquiring has been specially configured to run on a network, and consequently 
Symantec grants to you the right to use the enclosed Software on a computer network provided that for 
each and every concurrent user on the network, you have acquired and dedicated one licensed copy of 
the software.
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C H A P T E R 1
Overview

Visual Page is a complete tool for creating and publishing documents for 
the World Wide Web. It’s a visual-based designer, source code editor, and 
publishing utility, together in one package. You can use Visual Page to 
create all types of content, from basic Web pages to complex Web sites 
containing hundreds of pages.

This chapter provides a summary of the basic features of Visual Page, 
along with the system requirements of Visual Page and descriptions of the 
contents of this book and other Visual Page documentation.

About Visual Page
Symantec Visual Page is the fastest, easiest-to-use, what-you-see-is-what-
you-get (WYSIWYG) Web design software available on the market today. 
You can use Visual Page to bring dynamic and colorful Web pages to life 
without having to learn Hypertext Markup Language (HTML) formatting 
tags. Visual Page is as easy to use as your favorite word processor, yet has 
tools that are sophisticated enough to satisfy the most demanding user. 

Features
Several of the main features of Visual Page are described in this section.

Accessible and powerful feature set

Unlike most other HTML-based Web page editors, Visual Page displays 
your Web page so you see it as it’s created. Visual Page’s easy-to-use main 
editing window lets you create pages quickly, similar to creating files in a 
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basic word processor. You can drag and drop blocks of text, graphics, and 
other Web-based media onto a Web page, and Visual Page creates the 
necessary HTML code for you. 

Extensive HTML authoring tools

Visual Page doesn’t require that you enter complex HTML code — entering 
and modifying content is quick and easy. Advanced Web design elements 
are easily created and edited as well — for example, tables and frames can 
be inserted and manipulated with a minimum of steps, and without HTML 
coding.

If you prefer to directly control your HTML code, you can view and edit 
the HTML code generated by Visual Page in the source editor. Changes 
made in the source editor are automatically reflected in the main editing 
window, allowing for seamless navigation between the source and visual 
(main window) editor.

State-of-the-art media support

Visual Page offers a wide range of advanced Web media tools. Frames, 
tables, QuickTime movies, Navigator plugins, Java applets, JavaScript code 
and CGI-based forms can all be inserted effortlessly into your Web pages. 

Extensive template and sample set

The Visual Page Designer’s Toolkit consists of a number of templates and 
sample documents. The templates cover a wide range of document styles, 
and the sample documents cover a number of document types (such as 
product plans and registration forms). These templates can be used as the 
basis for your business or personal Web sites, saving you hours of design 
time in the process.

Site management tools

In addition to its sophisticated layout tools, Visual Page includes several 
Web site management tools. With Visual Page, you can create your Web 
site on your local hard drive, and then publish the entire site to a Web 
server, without ever leaving Visual Page. No third party utility packages are 
necessary. When you need to perform routine maintenance on your Web 
site (for example, deleting unneeded files), you can do that within Visual 
Page as well.
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Visual Page is also a useful tool for testing the links between pages in your 
site. Using Visual Page’s preview mode, you can test and correct links 
simply and quickly.

Updating Visual Page

Visual Page is equipped with a feature called LiveUpdate. Using 
LiveUpdate, you can access newer versions of the software as they become 
available. 

If your computer has a modem or an Internet connection, you can 
download Visual Page updates and additional product information using 
LiveUpdate. To receive an update, choose LiveUpdate from the Help 
menu, and follow the directions there.

System requirements

Visual Page's minimum system requirements are as follows:

• 80486 or higher, 66 Mhz minimum

• 8 megabytes of random access memory (RAM) minimum (12 
megabytes for Windows NT)

• 20 megabytes free hard disk space

• VGA card (Super VGA recommended)

• 256 or more colors (necessary for Java performance)

• Windows95/NT 4.0 installed

• CD-ROM drive

Note: In addition to the above system requirements, it is recommended 
that you have an Internet Service Provider (ISP) account and Web server 
account (included with many ISP accounts), in order to access and upload 
your Web site to the Web.

Visual Page’s documentation

Visual Page comes with a complete set of documentation and online help 
to assist you in the process of learning Visual Page. These documents are 
described below.
1-3
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User’s Guide

This may be the document you turn to most frequently as you work with 
Visual Page, as it contains step-by-step information on using Visual Page’s 
features. 

The eight chapters in this guide cover general topics involved with creating 
Web pages, such as text and graphics formatting, advanced Web features, 
site publishing, and site maintenance. The table of contents at the 
beginning of this guide lists the contents of these eight chapters, and the 
major subsections in each chapter. The glossary covers commonly used 
Web-related terms, and the index lists the contents of this guide by 
alphabetical index entry.

Visual Page Getting Started Guide

The Visual Page Getting Started Guide consists of installation instructions 
for Visual Page, and a Tour of Visual Page. The Tour is designed to 
familiarize you with the main features of Visual Page by guiding you 
through the process of building a working Web page. It requires no 
previous experience in Web page development. 

In the process of completing the Tour, you’ll learn to use many of Visual 
Page’s features, from creating a basic Web page to designing an entire Web 
site. The Tour is the quick way to learn Visual Page — and it’s fun!

Online help

Visual Page has an extensive help system, providing all of the procedures 
for building a Web page. To access Visual Page’s help, select Help Topics 
from the Help menu. For dialogs, toolbars, and windows, you can press F1 
to access Help that is specific to your current Visual Page activity.

Web basics
The foundation of accessing online media is a global set of interconnected 
computers called the Internet. Similar to the network you may use at work 
or school, but on a larger scale, the Internet is the “glue” used to connect 
computers together. 

Though it has been in use for over thirty years, the Internet became 
popular only recently, due to the graphics-based front end of the Internet: 
the World Wide Web (otherwise known as the Web). Unlike the Internet 
1-4



 

Web basics

                
tools that preceded it, the Web allows easy access to information on the 
Internet — so easy that people with little or no background with using 
computers can view text, graphics, and other forms of media through it. 

This section covers the basics of the Web and the common vocabulary 
associated with it, including the protocols used to format, save, upload and 
download Web-based media.

Publishing on the Web

One of the strongest potentials of the Web is its direct and easily 
implemented publishing abilities — it is possible to design an entire Web 
site in weeks (or even days) and place it up on the Web. Visual Page is 
designed to complement and expedite this process, via its wide range of 
visual tools. 

The components of Web-based publishing with Visual Page are:

• Web pages

• Web sites

• HTML (Hypertext Markup Language) formats

• File Transfer Protocol (FTP)

What are Web pages?

You use Visual Page to construct documents for the Web, more commonly 
known as Web pages. A Web page is a type of document, viewed in a 
Web browser. 
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An example of a Web page is the main page for Symantec’s local template 
files (located in the Templates subdirectory in your Visual Page directory 
on your computer), as shown below.

Visual Page takes care of your document’s layout while you drag and drop 
pieces of the Web page into place. This allows you to focus on the design 
of your document, rather than the manipulation of document codes. 

What is a Web site?

A Web site is a collection of Web pages, linked together to create a 
cohesive collection of information. 

A Web site typically is accessed via its home page. The home page may 
contain a topic list which links it to other Web pages within the Web site, 
as well as pages within other Web sites. The home page is usually named 
index.html, although some Web sites name their home page 
default.html or home.html.
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The home page from Symantec’s Visual Cafe Pro Web site (located at 
http://www.cafe.symantec.com) is shown below.

Web sites are typically accessed through a Web browser — a software 
application expressly for viewing Web pages. As you can see, Visual Page 
can download Web pages, in addition to browser applications such as 
Netscape Navigator or Microsoft Internet Explorer. 

For information about managing a Web site, see Chapter 8, “Managing and 
maintaining your Web site”.

What are HTML tags?

The formatting of a Web page is controlled by a collection of markup 
codes. These codes, called HTML tags, are used to create and control the 
display of your Web page. 
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To see HTML tags, the source code for the Visual Cafe Pro Web page 
(shown above in Preview mode) is displayed below.

HTML tags mark off parts of a Web page to display it in a certain style. 
These tags are interpreted by your Web browser with information about 
how the Web page content should be displayed. You can see these tags by 
opening any Web page file (ending with the .html or .htm suffix) with a 
text editor, word processor, or within Visual Page. 

Visual Page automatically generates HTML source code as you edit your 
Web page, interpreting the tags as you create them in the visual editor— 
no HTML coding is necessary for Web page creation. For more information 
about support of HTML tags in Visual Page, see “Working with text” on 
page 3-1.

What is FTP?

When you publish your Web site, you use a network protocol (a set of 
predefined commands) to place the files on a Web server — a computer 
that’s dedicated to storing and sending out Web-based files. The most 
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common protocol used for transferring files to a Web server is the File 
Transfer Protocol (FTP). Visual Page lets you use FTP in a visual format 
to upload files from your system to a Web server, rather than having to 
enter FTP instructions at a command line. From within its FTP window, 
Visual Page provides extensive FTP support, including the ability to 
upload, download, rename, and delete server-based files. 

The FTP window is shown below.

Hypertext and URLs

One of the characteristics that distinguishes Web-based publishing from 
other forms of publishing is its ability to create access paths between 
documents. The mechanism for creating these paths is called hypertext. A 
hypertext document is made up of links to other documents, combined 
with its displayed content. These links can connect to text, pictures, sound, 
animation, Java applets, and video clips, as well as to other Web pages. 

On the Web, hypertext is implemented by the following types of Web-
based components:

• Uniform Resource Locators (URLs)

• Links

• Anchors

What are URLs?

Visual Page uses the Uniform Resource Locator (URL) standard for 
determining where linked files are located. A URL consists of a type of 
1-9
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address that locates a Web page on the Internet in response to a browser 
request.

A typical URL looks like this:

http://www.symantec.com/tools/docs/User%20Guide.html#topic1

A URL can consist of up to five parts:

Protocol. The rules governing the transfer of data over the network; 
the Internet uses http (the HyperText Transfer Protocol).

Domain. The host name and Internet namespace; for example, 
www.Symantec.com.

Directory path. The file's location on its server; for example, tools/
docs.

Filename. The filename being linked to; for example, 
User%20Guide.html. The %20 is the HTML formatting code for a 
space character.

Anchor. The anchor, preceded by a number sign (#), refers to a 
specific location within a Web page. In this example, #topic1.

What are links?

Links allow you to connect other files to your Web pages. When a user 
clicks on a linked file, such as a piece of text, a graphic, or a portion of a 
graphic, their browser displays the file that the link points to. These files 
may be other Web pages, text, graphics or Web media (such as audio and 
video). 

Links embedded within text are easily identifiable. Most browsers default 
to coloring and underlining linked text, and users can set the color and 
underline options as they prefer. 
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A Web page with several links is shown below.

For more information on creating and editing links with Visual Page, see 
“Inserting links” on page 4-1.

What are anchors?

Anchors are used to mark specific locations within a document. Once an 
anchor is placed in a location, you can create a link to that spot. 

link to 
another 
Web page
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A page with anchors is shown below.

If you click on an object that is linked to an anchor in an external 
document, the document opens at the anchored location. Anchors that are 
within the same document as their target make the document scroll to the 
anchor's location. 

Visual Page represents anchors with an anchor icon, in both the Local Site 
window and in the Visual Page document in which they are placed. 
Anchors are inserted at the spot that you want to link to. Anchors aren’t 
visible when in Preview mode nor when viewing a page through a Web 
browser.

For more information on creating and editing anchors with Visual Page, 
see “Inserting anchors” on page 4-4.

Designing on the Web

In the past few years, a variety of design enhancements have been added 
to the initial HTML specifications, which was designed primarily for basic 
text formatting and display of static graphics. 

anchor

anchor
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These new features (which are implemented in Visual Page) include the 
following:

• Frame sets

• Tables

• Image maps

• Plugins

These features allow you greater control over the design of your 
document, and incorporate an expanded set of media within your Web 
sites. Visual Page provides extensive support for all of these features.

What are frame sets?

Frame sets divide a Web page into two or more independent sections 
(called frames), each displaying a separate HTML file. Each frame that is 
used within a Web page typically contains an HTML document within it. 
The page within a frame isn’t permanently connected to that frame: it can 
be replaced by another page, displayed as a single Web page, or removed 
altogether. 
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A page with frames is shown below.

Frames are commonly used to increase control over the layout of a Web 
page. For example, a frame set can have one frame that contains the links 
for a Web site, and another frame for displaying the target for the links. 

For more information about frames, see “Creating frame sets” on page 6-1.

What are tables?

Tables are used to present information in a uniform format (rows and 
columns). Like frames, tables are used to increase the amount of control 
that you have over your Web page design. Unlike frames, tables can be 
used to create a grid within a Web page; this grid can be as small as you 
want it to be, down to a single pixel. 

Visual Page supports a range of table design features, including:

• Inserting and deleting rows or columns

• Spanning cells over several rows or columns

• Adding color to a cell or to a whole table

Left 
frame

Right 
frame
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• Selecting multiple cells

For more information on tables, see “Creating tables” on page 6-14.

What are image maps?

An image that contains several links is called an image map. Visual Page 
provides a set of tools that are used to connect, or “map,” links to an 
image. Image maps are used to provide access to other Web pages or Web-
based files from within a single graphic. Using image maps can make your 
Web site easier to navigate, and because the links are in a single location, 
make it easier to maintain as well.

When you create a local image map, Visual Page stores the links in your 
Web page. This allows the image map links to display faster than the 
traditional method, which placed the links’ coordinates in a separate file, 
then stored the file on the site’s Web server.

For more information on image maps, see “Creating and editing image 
maps” on page 5-13.

What are plugins?

A plugin is an accessory to a Web browser. Plugins are commonly used to 
extend the range of features that a browser has—for example, display of 
three-dimensional images or audio files in a proprietary format. 

Since Visual Page supports the standard plugin protocols, any type of 
plugin file that displays within a standard browser can be included within 
Visual Page documents.

For more information on plugins, see “Inserting plugins” on page 7-1.

Programming on the Web

Visual Page provides support for a wide variety of Web-based 
programming platforms, including:

• Java applets

• JavaScript

• Form-based scripts and applications
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What are applets?

Visual Page supports the embedding of Java applets within Web pages. 
Java applets are interactive mini-applications (created with the Java 
programming language) contained within a Web page. Applets are useful if 
you want to embed software programs (such as calendars or alarm clocks) 
within your pages. Use Symantec’s Visual Cafe to create Java applets 
quickly and easily. 

Like other file types supported by Visual Page, applets can be dragged and 
dropped into any Web page. In addition, Visual Page provides a standard 
Java console window, for testing purposes.

For more information on applets, see “Inserting applets” on page 7-4.

What is JavaScript?

Netscape's JavaScript scripting language adds basic interactive 
functionality to HTML — for example, it can provide users with dynamic 
control over your Web site's content. Visual Page allows you to include 
JavaScript code within your Web site, either by inserting JavaScript code 
within an HTML file, or by linking to the files containing JavaScript code 
from within an HTML file.

For more information on JavaScript, see “Using JavaScript” on page 7-7.

What are forms?

Forms let users pass information (such as their name and address) from 
their browser to a Web server. Forms commonly interface with Common 
Gateway Interface (CGI) applications, which are computer programs that 
process the information that a user enters into a form, and then send the 
information to the Web server.

Visual Page provides an extensive range of form creation tools, including 
drag-and-drop form elements, support of CGI scripts, and insertion of 
multiple forms within a single HTML document.

For more information on forms, see “Creating forms” on page 7-9.
1-16



Web basics
What’s next

In the next chapter, we explore the essential features of Visual Page, 
including an overview of creating Web pages in Visual Page and 
information on setting Visual Page’s global and document preferences.
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C H A P T E R 2
Creating Web pages

Visual Page provides a wide range of features to aid you in trouble-free 
creation of Web pages. This chapter describes the basic components of 
these various tools, and how to control the document and global settings 
within Visual Page.

Launching Visual Page
Before you can use Visual Page, you need to install it on your computer. 
For installation instructions, see the Visual Page Getting Started Guide.

To launch Visual Page:

1 Click the Start button on the Taskbar. The Start menu appears.

2 Point to Programs. The Programs menu appears.

3 Point to Symantec Visual Page, and select the Visual Page 
program. Visual Page opens, with a new, untitled web page ready 
for editing.

Opening Web files

A Web file can be a Web page, an image, or a Web multimedia file. To 
open a particular Web file in Visual Page, you can navigate to the file from 
within Visual Page, or you can drag the file icon from Windows Explorer 
into the Visual Page environment. 

To open a Web file from within Visual Page:

1 With the Visual Page window open and active, select Open from 
the File menu. The Open dialog box displays.
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2 Select the desired file type from the drop-down menu.

3 Navigate to the desired file.

4 Click Open. The Web file opens in Visual Page.

To open a Web file by dragging the file icon from Windows Explorer:

1 Open Visual Page.

2 Open Windows Explorer. 

3 Arrange your Windows desktop area so that both the Visual Page 
and Windows Explorer windows are visible.

4 Using Windows Explorer, navigate to the desired Web file.

5 Select the desired file, and drag it to the Visual Page window. The 
file opens in Visual Page.

Once you’ve launched Visual Page, the main editing window appears, 
displaying an untitled Web page. The main editing window serves as the 
visual editor for Visual Page. This is where you’ll do most of your Web 
page formatting and editing.

The Visual Page interface
One of Visual Page’s strongest features is its intuitive yet powerful 
interface. Combining the best features of visual HTML editors and high-
level text-based Web authoring tools, the Visual Page interface allows you 
to create Web-based content quickly and completely, without having to 
resort to third party tools. 
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The main component of the Visual Page interface is its main editing 
window, shown below.

Visual Page’s toolbars, described below, provide access to the most 
commonly used features of Visual Page. The toolbars are the “central hub” 
of Visual Page’s main window — most of your Web page formatting can be 
done directly from it.

To view or hide a toolbar, choose Toolbars from the View menu. Select a 
toolbar that you wish to display, and deselect a toolbar that you wish to 
hide. You can also access this toolbar menu by right-clicking anywhere on 
a toolbar. You can also move toolbars around and place them anywhere 
within the Visual Page environment window.

Toolbars

Edit 
area

Link To 
field
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The table below displays the buttons in the Visual Page toolbars. 

Additional information on toolbar features can be found in the remaining 
chapters of this book.

Open a 
local site 
window

Insert Java 
Applet

Fixed width

Edit Page Insert 
Anchor

Decrease

Preview 
Page

Insert Table Increase

Edit Source Add Row 
Before

Text color

Page 
Properties

Add 
Column 
Before

Align Left

Object 
Properties

Delete Row Align Center

Hyperlink Delete 
Column

Align Right

Insert 
Horizontal 
Line

Format paragraph Decrease 
indent

Insert Image Bold Increase 
indent

Insert 
plugin

Italic Object 
Alignment
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Visual Page’s editing area is where you add or delete the elements of your 
Web pages — everything from text and graphics to tables and Java applets 
are placed here.

The Link To field is used to create links — connections from one Web page 
or Web element (such as a graphic or a sound clip) to another. For more 
information on creating links, see “Inserting links” on page 4-1. 

Setting preferences
When you start using Visual Page, you need to set up a variety of 
preferences. There are two groups of preferences within Visual Page: 
global preferences and page properties. The global preferences control the 
functioning of a number of essential features within Visual Page, from 
control of images to establishing a connection with your Web server. The 
page properties apply to a single Web page, and they handle the primary 
elements of the Web page’s appearance, from text color to background 
images.
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Setting the global preferences

To set Visual Page’s global preferences:

1 From the Edit menu, select Preferences. 

The Preferences dialog box opens, as shown below.

2 Select the tab for the category of preferences you want to set.

3 Select the desired option. The options for each category are 
described in the table below.

4 Click OK to save the your preferences changes. 
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The table below displays the categories of preferences available in the 
Preferences dialog box. An explanation of each preference option (within 
each category) is included.

Note: The table below assumes that you have the basic information for 
your Internet Service Provider (ISP) account, such as the requirements for 
the ISPs default file structure, default file names, and formats for server-side 
image maps. If you don't have this information, contact your ISP for details.

Preference category Description of preference options

General Sets miscellaneous attributes, including the 
following:

• Show or hide anchors in Site 
Window.

• Display only HTML and 
graphics files in Site Window.

• Insert an invisible character 
into empty table cells.

• Run Java applets in Preview 
mode.

Output Sets output defaults, including the following:

• Default file extension used for 
Web pages (.htm or .html)

• Default file name for server 
(index.html, home.html)

• Proprietary line separators for 
Mac, Unix, or Windows/DOS.

• Return key mapping (<P> or 
<BR>). For more information 
about this feature, see 
“Creating paragraphs and line 
breaks” on page 3-11.

• Software, author, and date 
information in file header 
(META tags).
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Images Sets image attributes, including the 
following:

• Placing converted images in 
the same folder as their source 
file. For information about 
using images in Visual Page, 
see “Inserting a graphic” on 
page 5-2.

• Assigning a global file folder 
for graphic storage and 
placement of converted 
images.

• Indicating the server-side 
image map format (to find out 
the type of image map format 
your Web server uses, contact 
your System Administrator or 
ISP). 

Folder mappings Sets mapping between local and remote 
folders. For more information on this feature, 
see “Mapping folders” on page 8-10.

Network Sets network connection attributes for 
uploading/downloading, including the 
following:

• Web server (ftp host)

• Web server directory (ftp 
directory)

• User name

• Password

For information on setting network 
attributes, see “Setting up your network 
connection” on page 8-1.

Preference category Description of preference options
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Some of the following buttons appear on each Preferences tab:

• Use Defaults: Click this button to use the default preference 
settings. 

• Revert: Click this button to go back to the preference settings that 
were in place before you opened the Preferences dialog box.

• Clear: Click this button to clear text entry fields.

• Apply: Click this button to apply the changes and keep the dialog 
box open.

• Cancel: Click this button to cancel any changes you’ve made to 
the preferences settings.

Setting Web page preferences 

If you want to customize the display of your Web page, Visual Page allows 
you to change specific features. 

To change the Page Properties for a Web page:

1 Choose Properties > Page from the Edit menu, or click the Page 
Properties button in the toolbar. 

Syntax color Sets color for different types of HTML syntax 
(as seen in the source editor), including the 
following:

• Plain text

• HTML tags

• HTML source code comments

• Form attributes

• Form values

Preference category Description of preference options
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The Page Properties dialog box is displayed below.

2 Use the attributes in the Page Properties dialog box to set the 
document’s attributes. These attributes are described in the table 
below.

3 Click OK when you’ve finished setting the desired options.

Preference type Description

Page Title The title of the document. This is NOT the 
same as the document’s filename — it is 
used for reference purposes only. It’s 
displayed in a brower application’s title bar.

Background color The background color.
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The following buttons appear on the Page Properties dialog box:

Apply: Click this button to apply the changes and keep the dialog 
box open.

Cancel: Click this button to cancel any changes you’ve made to the 
properties settings.

Normal text color The color of the document's text.

Normal links color The colors used for hypertext links. For 
more info, see “Setting the color for 
normal links” on page 4-6.

Active links color The color used for links as they are active. 
For more information, see “Setting the 
color for active links” on page 4-8.

Visited links color The color used for links that, when viewed 
in a browser, have been visited by a user. 
For more information, see “Setting the 
color for visited links” on page 4-8.

Background image Sets the background image for your Web 
page. For more information on this feature, 
see “Creating tiled backgrounds” on 
page 5-9.

Language Sets the language used. For this version of 
Visual Page, the only available language is 
Roman (English). International versions of 
Visual Page support Japanese, Traditional 
and Simplified Chinese, and Korean.

Base URL Sets the Base URL for your document. The 
Base URL is the directory location upon 
which all the links in a Web page are based. 
For more information, see “Moving files” 
on page 8-8.

Base target The base target for all the links in the Web 
page. This lets you specify whether links 
open documents in a new window, the same 
window, a new frame, or the same frame. 
For information on setting the base target for 
a frame, see “Setting the frame target” on 
page 6-11. 

Preference type Description
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Setting up your local Web site
Before you start creating a Web page, you need to identify a folder on your 
local hard drive where you’ll store the contents of your Web site — pages, 
graphics, and so on. This folder is your local Web site. Keeping all of your 
files within your local Web site makes it easier to keep track of your files, 
especially when it comes time to publish your Web site — if your files are 
all in one location, you won’t risk having to hunt for the files when it’s time 
to publish them.

You set your local Web site in Visual Page using the Local Site window. 
Visual Page’s Local Site window provides easy access to all of the files that 
will make up your Web site. 

The Local Site window can also be a useful tool in the maintenance of the 
Web files that make up your Web site, as it allows you to view (and open) 
all of the Web pages and graphics for your site. In addition, you can drag 
and drop files from the Local Site window into any open Web page.

To set your local Web site:

1 From the File menu, choose Open Local Site. 

A dialog box appears, displaying all of the drives and directories that 
are available to your computer.

2 Navigate to the parent folder of your site folder.

3 Click OK. 

A Local Site window for the selected folder appears.
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The Local Site window is shown below.

Once your local site is complete, you can publish the documents to your 
Web server — this allows other people to access your site via the Web. The 
version of your site that is accessible via the Web is called your remote 
Web site. For more information on publishing your Web site, see 
“Maintaining your Web site” on page 8-7.

Note: Once you create your local Web site, be sure to update your links 
when you move files from one location to another — if you move your 
files without changing your links, the links to the moved files may break. 

You can also use the Local Site window to create links and anchors. For 
more information, “Using the Local Site window to insert a link” on page 4-
2.

Starting a Web page
The first step in using Visual Page is knowing how to create Web pages. 
There are three ways that you can start a Web page: from scratch, from an 
existing Web page, or from a template. 
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Starting a Web page from scratch

Starting a Web page from scratch is the best approach if you want to create 
a completely original Web page. For example, if you have a client that 
wants to implement a completely new Web site design, this is the place 
you’d start. 

When creating a new page, be sure to decide if you want your page to be 
frame-based or not. Adding frames into a Web page at a later time involves 
extensive coding in HTML — enough so that you should plan this in 
advance and select the correct command when beginning the page.

To start a Web page from scratch:

• Select New from the File menu. If you plan for your Web page to 
include frames, select New Frame Set instead. 

A new, untitled Web page opens.

Now that you’ve got your Web page started, you can add text, insert 
graphics, tables, and advanced features — such as plug-ins, Java applets, 
JavaScript code, or forms. If you want to preview your document, or view 
its HTML source code, be sure to see the sections covering preview and 
source code modes later in this chapter.

After you’ve entered the content into your Web page, remember to save it. 
If you want, you can also print the Web page. Information on saving and 
printing your Web page is explained later in this chapter.

Starting a Web page from an existing page

You can use Visual Page to create a new page from an existing one. This is 
a good approach if you need to create several pages that are similar in 
appearance, as you won’t need to reenter the elements of your Web page 
every time. There are two ways to create a Web page from an existing one: 
starting from a Web page already stored on your computer’s hard drive, or 
by pulling a Web page from off of the Web. 

From your computer

To start a Web page based on an existing Web page stored on your 
computer’s hard drive:

1 Open the desired file in Visual Page.
2-14



Starting a Web page
2 Save the file under a new name by selecting Save As from the File 
menu. 

3 Modify the file as desired. Make sure to save your changes.

If you open a Web page that contains tags that aren’t supported by Visual 
Page, the opening and closing tags are indicated by opening and closing 
tag icons. To modify these tags, either double-click on them, or open the 
file in the source editor. For details on using the source editor, see 
“Viewing the HTML code” on page 2-17.

Now that you’ve got your Web page started, you can add, edit or delete 
text, graphics and other elements. See the appropriate chapters for 
information on how to do so. If you want to preview your document, or 
view its HTML source code, be sure to see the sections covering preview 
and source code modes later in this chapter.

After you’ve entered the content into your Web page, remember to save it 
under a new name. If you want, you can also print the Web page. 
Information on saving and printing your Web page is explained later in this 
chapter.

From the Web

If you have the URL for a Web page, you can download it from within 
Visual Page, then modify it to create a new page. 

To download an existing Web page:

1 From the File menu, select Download Remote File.

2 Enter the URL for the file.

3 Click OK. A Save As dialog box appears. 

4 Navigate to the folder that you want to save the file to and enter 
the new filename (if you wish to change it from the existing 
filename).

5 Click Save. The file you selected downloads, and displays.

Now that you’ve downloaded your Web page, you can add, edit or delete 
text, graphics and other elements. See the appropriate chapters for 
information on how to do so. If you want to preview your document, or 
view its HTML source code, be sure to see the sections covering preview 
and source code modes later in this chapter.
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After you’ve entered the content into your Web page, remember to save it. 
If you want, you can also print the Web page. Information on saving and 
printing your Web page is explained later in this chapter.

Note: Like most other types of media, Web pages are copywritable 
material. Exercise caution when downloading other people’s Web pages, 
especially if you plan to use all or part of what you download on your Web 
page. Generally speaking, unless you see an explicit statement on the Web 
site that the site’s contents are entirely of the Web author’s own creation, 
and are to be used freely and without charge, assume that the site’s 
contents are not for indiscriminate use.

Starting a Web page from a template

Visual Page includes several ready-made templates that can be used as the 
basis for Web pages. When you create a page based on one of these 
templates, all of the text formatting, graphics, and other elements within 
the template page are included in your new page. This can save you a 
great deal of design time over creating a page from scratch. It also gives 
you a good foundation for creating your Web site.

To start a Web page from a template:

1 From the File menu, select Open. Select the file “Visual Page.html” 
in the Templates subdirectory. in your Visual Page directory.

2 Click Open. The Visual Page Designer’s Toolkit displays. 

3 If Visual Page isn’t in preview mode, change to this mode by 
clicking on the Preview Page toolbar button.

4 Click the Templates button in the Web page. The templates page 
displays.

5 Make sure that you’re in Preview mode by clicking on the Preview 
Page toolbar button.

6 Read the description of the Visual Page templates, then choose a 
template from the Web page icons.

7 From the File menu, choose Save As. The Save As dialog box 
appears.

8 Enter the filename for your Web page, and click OK. You now 
have your own Web page, based on one of the template pages.
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Now that you’ve got your Web page started, you can add, edit or delete 
text, graphics and other elements. See the appropriate chapters for 
information on how to do so. If you want to preview your document, or 
view its HTML source code, be sure to see the sections covering preview 
and source code modes later in this chapter.

Previewing your work
Visual Page provides two modes for working with Web pages. The edit 
mode is used to create and modify Web-based content. The preview 
mode is a way to view documents as they appear in a user’s browser.

To switch to the edit mode, click the Edit toolbar button. Likewise, to 
switch to the preview mode, click the Preview toolbar button.

Viewing the HTML code
In addition to modifying Web content in the edit window, you can edit the 
HTML code for your Web pages in the source editor. The source editor 
allows you full control over the code that makes up your Web page. It is 
similar to using a text editor to create HTML code, but includes additional 
features, such as automatic coloring of HTML tags.

Changes that are made in the source editor are automatically reflected in 
the edit area of the main editing window, once the main editing window is 
made active. For example, if you enter the source code for a Heading 1 tag 
(<H1> and </H1>) in the source editor, then select the main edit window, 
the area you put the tags around appears in Heading 1 format.

To switch to the source editor:

1 Select the Edit Source button from the toolbar, or select Edit 
Source from the View menu.
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The source editor is displayed below.

Saving a Web page
As you are creating your Web pages, it is a good idea to save your work 
periodically.

To save a Web page:

1 From the File menu, select Save. If you want to save a previously-
saved file under a different name, select Save As. 
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The Save (or Save As) dialog box opens, as shown below.

2 Navigate to the folder to which you want to save the file. 

3 If this is the first time you’re saving this file, enter a name for the 
file. The file extension will automatically be added, according to 
the file extension preference setting. For more information, see 
“Setting the global preferences” on page 2-6.

4 Click Save.

Printing a Web page
Visual Page supports WYSIWYG printing of Web pages. The default print 
setting is to print one copy of the entire document.

To print a Web page:

1 (optional) From the File menu, select Print Setup and select the 
page size, orientation, and printer effects you want. Visual Page 
remembers the settings once you click OK.
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2 From the File menu, select Print. The Print dialog box opens, as 
shown below.

3 Enter the printing-specific information for your print job.

4 Click OK.

What’s next

In the next chapter, we cover Visual Page’s extensive features for creating 
and formatting HTML-based text, including text alignment, paragraph and 
character formatting, and manual insertion of HTML tags.
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Working with text

Visual Page offers a full range of Web-based authoring tools. Working with 
text in Web pages in Visual Page is very similar to inserting text using any 
standard word-processing application. For example, you can add structure 
and style to your text by applying formatting and styling options, such as 
bold and italic text.

This chapter covers the range of text insertion and manipulation tools 
within Visual Page, including formatting of paragraphs and characters, text 
alignment and coloring, and insertion of HTML tags. 

Inserting text into a Web page
You enter text by typing in the main edit window. Any text you enter 
appears at the insertion point, which is indicated by the text cursor. The 
text cursor appears as blinking vertical line.

The main ways of inserting text in Visual Page are typing, dragging and 
dropping, and copying and pasting.

After you finish inserting your text, don’t forget to preview your Web page. 
For instructions on using the Preview mode, see “Previewing your work” 
on page 2-17.

Typing text into a Web page

To insert text into a Web page by typing:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 
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2 Position the insertion point by placing the cursor over the desired 
insertion point and single-clicking.

3 Enter your text.

Dragging and dropping text into a Web page

To insert text into a Web page by dragging and dropping from another 
Web page:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Open the Web page from which you want to drag the text. This is 
the source page.

3 Open the Web page into which you want to drag the text. This is 
the destination page.

4 Arrange the two Web page windows so that you can see both on 
your computer screen.

5 Within the main edit window of the Web page that contains the 
source text, select the text you want to insert into the other Web 
page.

6 Place the mouse pointer on the selected text and drag the text to 
the location in the destination Web page. 

7 Release the mouse button. Your text is moved from the source 
Web page to the destination page.

Copying and pasting text into a Web page

To insert text into a Web page by copying and pasting:

1 If the Web page that you want to copy the text from isn’t open, 
open it now. This is the source page.

2 If the Web page that you want to paste to isn’t open, open it now. 
This is the destination page. Make sure that this page is open in 
Edit mode by clicking the Edit Page toolbar button.

3 Within the main edit window of the source page, select the text 
you want to insert into the destination page.

4 From the Edit menu, select Copy.

5 Move the text cursor to the place in the main edit window where 
you want the insertion point placed, and single-click.
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6 From the Edit menu, select Paste. The text is copied to the new 
location.

Tip: If you are in Preview mode, you can automatically switch to Edit 
mode by typing in text. Visual Page places the text at the last cursor 
position in the active Web page.

Formatting text
Visual Page supports two types of text formatting: paragraph formatting 
and character formatting. 

Paragraph formatting is used to apply a group of predefined formats 
(called a style) to one or more paragraphs. For example, if you want to 
apply a heading to a section of your Web page, the Heading 1 style applies 
all the formats that make up the style the moment that it’s applied, so you 
don’t have to apply all of the formats by hand.

Character styles are used to make individual characters or groups of 
selected characters stand out in your text, for example, applying bold or 
italic to a section of text increases the visibility of a word within a text 
block. 

If you want to review the HTML code for your Web page, you need to go 
into the source editor. For details on using the source editor, see “Viewing 
the HTML code” on page 2-17.

Formatting paragraphs

Paragraph formats are predefined text styles. They are intended to be 
applied according to the type of information contained within their target 
paragraph; for example, you would apply the Heading 1 format to the 
topmost headers in your Web page.

Paragraph formats are ultimately determined by Web browser settings 
rather than the formats you apply. For example, a bullet list may look 
different in various browsers, depending on the settings each uses. The 
actual font and font size your paragraph displays is set in the Web browser 
by the person viewing your Web page. 

Visual Page supports the following paragraph format styles:

• Normal
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• Headers

• Preformatted

• Address format

• List formats

• Term and Description

Normal

The Normal style is the default format when you create a new paragraph. 
The text appears flush left in the page window and is displayed in the 
Visual Page default font. This style is also selectable from the style drop-
down menu. Most of the text in your Web pages should be formatted with 
this style.

To apply the Normal style:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraph you want to format by clicking anywhere 
within it.

3 Click the arrow in the style box on the toolbar. A drop-down list of 
paragraph styles appears.

4 Choose the Normal style.

Headers

Header styles are used to make headlines or titles distinct from the rest of 
the text in a page. In general, headers are larger than the Normal format, 
and are in a bold type face. Visual Page supports the heading styles 
Heading 1 through Heading 6.

To apply a header style:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraph you want to format by clicking anywhere 
within it.

3 Click the arrow in the style box on the toolbar. A drop-down list of 
paragraph styles appears.

4 Choose a header style (Heading 1 – Heading 6).
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An alternative to using a header format is to manually specify the font size 
of a text block, using the Increase Font Size button. Creating headers in this 
way allows you greater control over the relative size of your headers.

Preformatted

The Preformatted paragraph style is used as a way to maintain text 
formatting that uses multiple spaces and tabs, such as the formatting found 
in code segments. 

Preformatted paragraphs are displayed in mono-spaced fonts, such as 
Courier. Monospaced fonts use equal spacing for all characters, regardless 
of the individual character’s size: for example, the letter “l” takes up the 
same amount of space as the letter “W”. This allows for easy formatting of 
large blocks of difficult to read text, such as is found in computer code.

To apply the Preformatted style:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraph you want to format by clicking anywhere 
within it.

3 Click the arrow in the style box on the toolbar. A drop-down list of 
paragraph styles appears.

4 Choose the Preformatted style.

Address format

Web site authors typically apply the Address style to the paragraph that 
contains a contact address for the creator of the Web site. As is the case 
with all the paragraph formats, the final appearance is dependent on the 
browser which displays it. Most Web browsers use an italic format in the 
Address style, which is the convention Visual Page uses as well. 

Choosing to include an address is a matter of style. When you include an 
address, make sure to link it so that the browser jumps to email when the 
link is clicked. 

Note: The Address style does NOT create a link to an email address! To 
create an email link, see “Creating email address links” on page 4-9.

To apply the Address style:
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1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraph you want to format by clicking anywhere 
within it.

3 Click the arrow in the style box on the toolbar. A drop-down list of 
paragraph styles appears.

4 Choose the Address style.

Bullet lists

When you apply the Bullet style to a paragraph, Visual Page indents the 
text and places a bullet character to the left of the text in the paragraph. 
You use this style to create bullet lists — an unordered list of items or 
topics. This is useful if, for example, you want to create an online 
presentation highlighting several main topics.

To apply the Bullet style:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraphs you want to format.

3 Click the arrow in the style box on the toolbar. A drop-down list of 
paragraph styles appears.

4 Apply the Bullet style.

When you create a bulleted list, the paragraph automatically indents, to set 
off the bullets from the list items. You can create nested lists of bulleted 
items by changing a bulleted paragraph’s indentation. For information on 
changing a paragraph’s indentation, see “Indenting paragraphs” on page 3-
8.

Ordered lists

There are several types of ordered lists. You may find them useful in 
creating different styles of outlines or steps. 

When you apply any of the ordered list styles to a paragraph, the ordered 
style indents the text and places a number or letter to the left of the 
paragraph. 

Visual Page supports Netscape's extensions to HTML ordered lists. These 
extensions make different kinds of ordered lists possible, including 
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uppercase and lower case letters, uppercase and lower case roman 
numerals, and regular numbers (1, 2, 3).

To create an ordered list:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraphs that you want to format.

3 From the Format menu, select List. A menu displays the list types 
available.

4 Select the type of ordered list that you want to use.

Term and description lists

The term and description styles are designed to be used together in lists of 
definitions. The format is similar to what you would find in a Glossary: the 
Term style is used to format the glossary word, and the Definition style is 
used to format the definition of the word.

Applying the Term format to a paragraph places the paragraph text flush 
left at the left margin. When you press the return key after applying a Term 
format to a paragraph, Visual Page automatically applies the Description 
format, then indents the text of the paragraph.

To create a term and description list:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraph you want to format as a term by clicking 
anywhere within the paragraph.

3 Click the arrow in the style box on the toolbar. A drop-down list of 
paragraph styles appears.

4 Select the Term style to apply it.

5 Select the paragraph you want to format as a description by 
clicking anywhere within the paragraph.

6 Click the arrow in the style box on the toolbar. A drop-down list of 
paragraph styles appears.

7 Select the Description style to apply it.

8 Repeat steps 2-7 for the remaining terms and definitions.
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Aligning paragraphs

Visual Page enables you to align paragraphs, similar to the alignment 
formatting used in a word processor: left, right or center. 

To align a block of text:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraph you want to format by clicking anywhere 
within it.

3 Click the Align Left, Align Center, or Align Right alignment buttons.

Indenting paragraphs

You can indent blocks of text with the Decrease Indent or Increase Indent 
buttons. 

To indent a block of text:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the paragraph you want to format by clicking anywhere 
within it.

3 Decrease or increase the paragraph’s indenting, by clicking the 
appropriate indentation buttons.

Formatting characters

Use character styles to make individual characters or groups of selected 
characters stand out in your text. 

To apply a character style:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the character(s) you want to format by clicking at the 
insertion point, then dragging to the end of the selection.

3 Choose a character style from the Style menu.
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The character styles supported by Visual Page are described in the table 
below.

Note: Though some of these character styles are similar, how they display 
depends on each browser’s settings. 

Table 3-1

Character style Description

Plain Unformatted text.

Bold Bold text; for example, bold.

Italic Italicized text; for example, italic.

Superscript Superscripted text; for example, 1.

Subscript Subscripted text; for example, 1.

Strike Thru Strike-through text; for example, delete this 
phrase.

Fixed Width A non-proportional font (similar to the 
Preformatted paragraph style); for example, 
fixed width.

Emphasis Italicized text; for example, italic.

Strong Emphasis Bold text; for example, bold.

Citation Italicized text; for example, italic.

Code A non-proportional font (similar to the 
Preformatted paragraph style); for example, 
code.

Variable Italicized text; for example, italic.

Keyboard A non-proportional font (similar to the 
Preformatted paragraph style); for example, 
keyboard.

Sample A non-proportional font (similar to the 
Preformatted paragraph style); for example, 
sample.
3-9



Chapter 3: Working with text
Changing the font size

Visual Page allows you to set the relative font size of a block of text. For 
example, if you want to create a drop cap (a type of formatting where the 
first character of a paragraph is larger than the rest of the paragraph), 
Visual Page’s formatting tools let you do this.

Visual Page uses font size 3 as the “normal” font size. This size is 
equivalent to the size of the display font, as set in the Web browser. The 
other numbers signify either a smaller or larger font than the one set as 
normal in the browser, with 1 being the smallest font size and 7 the largest 
font size. 

Note: A Web page’s text size is relative to the size set in a user’s Web 
browser. This is why the font sizes in Visual Page are indicated as 1 
through 7, instead of the numbers you see in a word processor, like 12 or 
14. The numbers in a word processor refer to the point size of a font, 
which is a standard rule of measurement (1 point = 1/72nd of an inch). As 
HTML-based font sizes are based on a user’s browser settings, fixed 
measurements (such as inches and point sizes) aren’t relevant for Web 
pages.

To change the font size:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the text you want to resize by clicking at the insertion point, 
then dragging to the end of the selection.

3 Click the Decrease or Increase button in the toolbar.

4 (optional) Check the size of the font by choosing Size from the 
Style menu. The size is indicated by a checkmark.

If you want to change the font size of a line of text, you can use a header 
style. For more information, see “Headers” on page 3-4.

Coloring text

Visual Page allows coloring of text, based on the standard Windows color 
palettes. 
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To color a block of text:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select a block of text to color by clicking at the insertion point, 
then dragging to the end of the selection.

3 Click the Text Color button in the toolbar. A color palette menu 
appears.

4 Select the color you want from the color palette. 

If you want a custom color, click Custom and create your color by 
clicking in the color box or by setting the Hue, Saturation, 
Lumination, and Red, Green, Blue amounts. Once you’ve created the 
desired color, click the Add to Custom Colors button, and your 
custom color is added to the Custom colors palette area.

5 When you’ve chosen the color you want, click OK.

Creating paragraphs and line breaks
Visual Page supports two types of text line separators: paragraph markers 
and line breaks. A line break simply indicates the ending of a line, where a 
paragraph marker indicates the ending of a style’s formatting block. For 
example, if a block of text has the Heading 1 style applied to it, this 
formatting will end once a paragraph marker is encountered. 

The Return key is set to either insert a line break or a paragraph marker, 
depending on the settings in the Output section of the Preferences 
window. For information about the Preferences window, see “Setting 
preferences” on page 2-5. 

The Shift-Return key combination always generates the opposite of what 
the return key setting is; for example, if the return key is set to insert a 
paragraph marker, Shift-Return will insert a line break. 

Adding additional HTML styles
In addition to the wide range of styles that Visual Page supports, Visual 
Page lets you insert any HTML tags as well, including browser-specific 
tags. This allows you to expand your range of text formatting options as 
new HTML tags become available. 
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When inserting a HTML tag, include both the beginning and ending tags, 
when applicable. For example, the <STYLE> tag must have a 
corresponding </STYLE> tag, otherwise all of the text and graphics 
following <STYLE> will be formatted with the <STYLE> tag until the end of 
the Web page.

To insert an HTML tag:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place the insertion point where you want the tag.

3 Choose HTML Tag from the Insert menu.

4 Type in the desired HTML tag in the HTML tag field, without 
opening and closing brackets (< and >). For example, to insert a 
<STYLE> tag, type STYLE.

5 Press OK.

Visual Page inserts the tag and represents it with a tag marker.

After you finish entering your HTML tags, you can preview your Web page. 
For more information, see “Previewing your work” on page 2-17.

Adding HTML tags to a source file
In addition to adding HTML tags via the HTML tag menu, you can add 
HTML tags directly into Visual Page’s source window. 

Note: The steps below assume that you are familiar with entering HTML 
tags manually.

To add HTML tags to a Web page through the source editor:

1 Open a Web page.

2 Go into the source editor by selecting the Edit source button from 
the toolbar, or by pressing Ctrl-Shift-E. 

3 In the main edit window, place the text cursor where you want to 
add the tag.

4 Enter the HTML tags. 

5 Switch to the visual editor. Your tags are reflected accordingly.

6 Save your work by choosing Save or Save As from the File menu.
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Adding special symbols and characters
You can add special symbols and characters to your Web pages without 
needing to know the HTML code for them. Accented characters and 
symbols such as trademark, copyright, and others are available to you.

Normally, to insert special symbols and characters which don’t appear on 
standard keyboards, you need to open a Web page’s source HTML code, 
and enter a special numbered code. Since remembering these codes can be 
tiresome, we’ve included the entities.htm file for your convenience. 

If you prefer to enter the symbol or character HTML codes yourself, you 
can do that the same way you enter HTML tags in the source editor. See 
“Viewing the HTML code” on page 2-17 for more information on editing 
the HTML source of a Web page.

To add special symbols or characters to a Web page:

1 Open or create a Web page. 

2 Make sure you’re in Edit mode by clicking the Edit Page toolbar 
button.

3 Select Open from the File menu, and navigate to the Samples 
subdirectory in the directory where you’ve installed Visual Page.

4 Select entities.htm, and click Open. 

A web page displays, containing listings of special symbols and 
characters.

5 Find the character or symbol you want to use, and highlight it to 
select it.

6 From the Edit menu, choose Copy.

7 Place the insertion point in your Web page where you want the 
symbol or character to appear.

8 From the Edit menu, choose Paste.

The character or symbol appears in your Web page.

What’s next

In the next chapter, we explore creating, formatting, and testing hypertext-
based links and anchors in Visual Page.
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C H A P T E R 4
Adding links and anchors

Links and anchors allow you to create connections between Web pages. 
When a user clicks on a link in a browser application, the browser displays 
the Web page that the link or anchor points to. The link can be an object, 
text, an image, or a portion of a image. 

This chapter covers the processes of inserting and manipulating links and 
anchors within Visual Page by using a variety of tools, and the steps 
involved in testing your links and anchors.

Inserting links
Visual Page lets you insert links in a variety of ways, including dragging 
and dropping from the Local Site window onto a selection, entering an 
URL for a file or anchor in the Link To field, dragging and dropping from 
the desktop onto a selection, and inserting a link with the Hyperlink 
toolbar button.

By default, the target display window for a link is the same window as the 
original file. This default can be changed in the Page Properties dialog box. 
For more information on setting the target display, see “Setting the frame 
target” on page 6-11.

After inserting your links, you may want to preview your Web page to 
make sure your links are entered properly. For details on using the 
Preview mode, see “Previewing your work” on page 2-17. If one or more 
of your links don’t work properly (for example, if an URL is entered 
incorrectly), follow the steps in “Testing and fixing links and anchors” on 
page 4-9.
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Using the Local Site window to insert a link

One of the easiest ways to create a link in Visual Page is to use the Local 
Site window as a place to drag Web pages and anchors from. For 
information on setting up your Local Site window, see “Setting up your 
local Web site” on page 2-12.

To create a link with the Local Site window:

1 Open a Local Site window for your current Web site by selecting 
Open Local Site from the File menu.

2 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

3 To select a portion of your text, click and drag over the desired 
area. To select a graphic, click anywhere on it once. 

4 Drag the icon for the Web page or anchor (that you want to link 
to) from the Local Site window to the selection in your Web page. 
Visual Page creates the link.

5 Look at the Local Site window after you save your Web page. The 
Web page that the anchor was placed in now has a plus sign next 
to it. When you click on the Web page’s plus sign, the named 
anchor becomes visible. 
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Using the Link To field

You can link graphics and text by entering the URL in the Link To text 
field. 

To create a link with the Link To field:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the object to be linked.

3 Type in the filename or URL in the Link To edit box, located at the 
bottom of the main edit window.

4 Press Enter. 

Visual Page creates the link.

Using the desktop to insert a link

To create a link from the desktop:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 To select a portion of your text, click and drag over the desired 
area. To select a graphic, click anywhere on it once. 

3 From the desktop, click on the file to be linked to, then drag the 
file onto the selected area in Visual Page. 

Visual Page creates the link.

Using the Hyperlink button

To create a link using the Hyperlink button:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the object to be linked.

3 Select the Hyperlink button in the main toolbar. The Link dialog 
box appears.

4 Type in the filename or URL of the file to be linked to, or click 
Browse. Use the resulting dialog box to navigate to the file.

5 Click OK.

Visual Page creates the link.
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Inserting and displaying anchors
In contrast to links, anchors are used to mark specific locations within a 
Web page. Visual Page represents anchors with an anchor icon, in both the 
Local Site window and in the Web page in which they are placed. 

Note: The various link insertion techniques described in “Inserting links” 
on page 4-1 may be used for anchor generation as well; for example, you 
can use the Local Site window to insert anchors and links.

Inserting anchors

To add an anchor to a Web page:

1 Scroll to the location you intend to mark with an anchor.

2 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

3 Insert your cursor at the desired location.

4 Click on the Insert Anchor button in the toolbar. The Anchor 
Properties dialog box appears. 

5 Name the anchor so that it is easy to find in the Local Site window 
when you need it. 

6 After you enter a name, click OK. An anchor icon appears in your 
text. 

7 Save your Web page.

You can quickly create of anchors by selecting a word at the location 
you're linking to and then clicking the Insert Anchor button. The selection 
you made appears automatically as the name of the anchor.

Displaying anchors

You can use the Local Site window to display all of the anchors in your site 
folder’s files. This can be useful, for example, in keeping track of your 
anchors across a large Web site.
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To display all of the anchors within your site folder’s files:

1 Make sure that the “Show anchors in the Local Site window” 
option is selected in the General Preferences tab. For more 
information, see “Setting the global preferences” on page 2-6.

2 Open a Local Site window by selecting Open Local Site from the 
File menu. 

Within the Local Site window, locate a Web page that contains anchors, 
and click the + (plus sign) next to it. A Web page’s anchors will be listed, 
and each anchor name has an anchor icon next to it, as shown below:

To display a dialog box listing the anchors in a Web page:

1 Select the text you wish to make into a link.

2 Right-click over the selected text. A menu appears.

3 Choose Link to. The Link dialog box appears.
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4 From the anchor drop-down menu, select an anchor. 

Visual Page automatically links the selection to the chosen anchor.

Coloring links
Visual Page supports customized setting of link colors. Color settings for 
normal, active, and visited links are supported. These link settings change 
the default settings for a Web page. If a user changes the link colors in their 
browser, those user-defined settings will override your defaults.

Setting the color for normal links

Normal links represent the color for non-active hypertext links that haven’t 
been visited by a user within a browser-specified period of time. 
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To change the color for normal links:

1 From the toolbar, click the Page Properties button. The Page 
properties dialog box displays, as shown below.

2 In the Page Properties dialog box, click the Normal Links button.

A color palette appears.

3 Select the color you want from the color palette. 

If you want a custom color, click Custom and create your color by 
clicking in the color box or by setting the Hue, Saturation, 
Lumination, and Red, Green, Blue amounts. Once you’ve created the 
desired color, click the Add to Custom Colors button, and your 
custom color is added to the Custom colors palette area.

Click 
here
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4 When you’ve chosen the color you want, click OK.

Setting the color for active links

Active links are hypertext links that have been clicked by a user. 
Specifically, an active link is indicated as the state between when a user 
clicks on a link and when they release the mouse button, thus indicating to 
the browser to load the linked Web page.

To change the color for active links:

1 From the toolbar, click the Page Properties button.

2 In the Page Properties dialog box, click the Active Links button.

3 Select the color you want from the color palette. 

If you want a custom color, click Custom and create your color by 
clicking in the color box or by setting the Hue, Saturation, 
Lumination, and Red, Green, Blue amounts. Once you’ve created the 
desired color, click the Add to Custom Colors button, and your 
custom color is added to the Custom colors palette area.

4 When you’ve chosen the color you want, click OK.

Setting the color for visited links

Visited links are hypertext links that have been previously visited, within a 
browser-based timeframe set by the user. 

To change the color for visited links:

1 From the toolbar, click the Page Properties button.

2 In the Page Properties dialog box, click the Visited Links button.

3 Select the color you want from the color palette. 

If you want a custom color, click Custom and create your color by 
clicking in the color box or by setting the Hue, Saturation, 
Lumination, and Red, Green, Blue amounts. Once you’ve created the 
desired color, click the Add to Custom Colors button, and your 
custom color is added to the Custom colors palette area.

4 When you’ve chosen the color you want, click OK.
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Creating email address links
You can provide a linked email address on your Web page. When a user 
clicks a linked email address, the browser's email editor displays with the 
linked email address in the recipient address field.

To provide a linked email address:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Create the text for the link. Most Web designers set the text for an 
email address link to the email address itself. For example, 
auser@symantec.com.

3 Select the link text.

4 Click on the Link to: field and enter the following text:

mailto:user@company.com

The user is the email address of the person being emailed and 
company.com is their Internet host.

5 Press Enter to save the link.

Note: The mailto: link is not the same as the <ADDRESS> tag. For 
information on the <ADDRESS> tag, see “Address format” on page 3-5.

Testing and fixing links and anchors
It's easy to break links when you're constructing a Web page. Since links 
are really URLs which record the location of a file or anchor, you can break 
a link by inadvertently changing the name of a file or the folders in which 
the file resides. As such, you should test your links periodically to make 
sure they work. 

Testing links and anchors

In Visual Page, there are three ways to test links and anchors:

1 If you aren’t in preview mode, click the Preview toolbar button to 
go into preview mode. Click on a link. If the correct linked file 
opens, the link is OK. If any other behavior occurs, the link may 
be broken. 
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2 While in edit mode, hold down the Control key while clicking the 
link. If the correct linked file opens, the link is OK. If any other 
behavior occurs, the link may be broken. 

3 Choose Preview in Browser from the View menu. This opens your 
Web page in the default browser. Click on a link. If the correct 
linked file opens, the link is OK. If any other behavior occurs, the 
link may be broken. 

Note: Some browser programs don’t automatically redisplay corrected links 
when a revised Web page is displayed. If you encounter this problem, try 
clearing your browser’s cache, and the updated links should display 
properly. For details on how to clear the cache for your browser’s software, 
consult your browser’s documentation.

Locating and fixing broken link errors

Make sure that all of the characters in your links are correct. One missing 
or incorrect character is all it takes to break a link.

To identify the source of a broken link, look for one or more of the 
following three errors within the link’s URL:

1 One or more incorrect characters in the URL for the Web page 
being linked to. 

2 A URL that attempts to connect to a deleted or non-existent Web 
page. 

If you suspect that a Web page doesn’t exist, attempt to connect to 
the Web page in question with your browser software. If you can’t 
load the Web page, either replace the Web page (if the Web page is 
part of your site), notify the administrator of the Web site that the 
Web page doesn’t exist, or change the URL in the link to point to a 
different Web page. 

3 Links that connect to a different Web page than the Web page 
desired to be linked to. 

If any of these errors occur, use one of the techniques described in 
“Inserting links” on page 4-1 to re-enter the link.
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What’s next

In the next chapter, we cover the many graphics-based features of Visual 
Page, including graphics insertion and alignment, setting graphic attributes, 
creation of transparent graphics, using tiled backgrounds in your Web 
pages, and creating image maps.
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C H A P T E R 5
Using graphics and image 
maps

Visual Page provides all the tools you need to include graphics in your 
Web site. This chapter covers the range of Visual Page’s graphics features, 
including types of supported graphics, graphics alignment, flowing text 
around graphics, and creation of transparent images and tiled 
backgrounds.

Supported graphic file types
The most common graphic file formats in use on the Web today are the 
GIF (Graphic Interchange Format) and JPEG (Joint Photographic Experts 
Group) formats. Both of these formats are supported by Visual Page. 

GIF

The GIF format is the most commonly used Web format. Its low overhead 
and support by all browsers currently available make it the format of 
choice for most graphics. 

JPEG

The JPEG format is primarily used for Web-based photographs, due to its 
relatively high display quality. Its main disadvantage is that its overhead is 
greater on average than equivalent GIF images.
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Inserting a graphic
You insert graphics in the main edit window. The main ways of inserting 
graphics in Visual Page are dragging and dropping from the Local Site 
window, choosing the toolbar’s Insert Graphic button, selecting Image 
from the Insert menu, or copying and pasting a graphic into your Web 
page.

After you finish inserting your graphics, you can see how they fit into your 
Web page’s layout by previewing your Web page. For information on using 
the Preview mode, see “Previewing your work” on page 2-17.

Using the Local Site window to insert a graphic

To insert a graphic using the Local Site window:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Open a Local Site window for the folder that contains the graphic 
by selecting Open Local Site from the File menu. For information 
on setting up your Local Site window, see “Setting up your local 
Web site” on page 2-12.

3 Within the Local Site window, click the image file to select it. 

4 Drag the selected graphic from the Local Site Window to the Web 
page, and release the mouse button once you have placed the 
graphic in the desired location.

Using the toolbar to insert a graphic

To insert a graphic from the toolbar:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 
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2 From the toolbar, click the Insert Image button. The Open dialog 
box appears, as shown below.

3 Navigate to and select the image file that you want to insert.

4 Click Open. The image appears in your Web page.

Using the Insert menu to insert a graphic

To insert a graphic from the Insert menu:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 From the Insert menu, choose Image. The Open dialog box 
appears.

3 Navigate to and select the image that you want to insert.

4 Click Open. The image appears in your Web page.

Copying and pasting a graphic

To copy and paste a graphic into a Web page:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 If the Web page that you want to copy the graphic from isn’t open, 
open it now.
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3 Within the main edit window of the Web page that contains the 
graphic, single-click on the graphic. 

4 From the Edit menu, select Copy.

5 In the Web page that you want the graphic to be copied to, 
position the insertion point where you want the graphic to appear. 
You position the insertion point by placing the cursor over the 
desired location, and clicking once.

6 From the Edit menu, select Paste. The image appears in the Web 
page.

Aligning graphics
Visual Page supports HTML tags that enable you to position graphics, 
tables, applets, movies, or other plug-in objects relative to the text in your 
Web page. This allows you to center a small graphic within a line of text, 
or flow text around a larger image or object. 

The Object Alignment pop-up menu on the Visual Page toolbar contains 
the alignment options Top, Bottom, Middle, Left, and Right. The Graphic 
Alignment functionality is also available in the Format menu under Object 
Alignment. 

In general, you use the first three alignment options (Top, Bottom and 
Middle) for small graphics that appear in a line of text. You use the Left 
and Right alignment options when you want to flow a paragraph of text 
around a larger graphic.

To align a graphic:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 From the main edit window, select the graphic you want to align.

3 Click the Object Alignment button.

The Object alignment pop-up menu displays.

4 Chose an alignment option. The graphic aligns according to your 
selection.

Flowing text around graphics
Visual Page provides full support for flowing text around graphics. 
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To flow text around graphics in your Web page:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select a graphic in a Web page.

3 Click on the Object Alignment button, and select Left.

4 Insert your cursor to the right of the graphic and enter a paragraph 
or two of text. When the line wraps it returns to the right edge of 
the graphic, until it reaches the bottom of the graphic. 

An example of a text block flowing around a left-aligned graphic is shown 
below.

Setting a graphic's attributes
Visual Page supports a range of attributes that are contained within any 
supported graphic. These attributes control the height, width, function, 
alternate text, and spacing around a graphic.

To set a graphic's attributes:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select a graphic in a Web page.

Left 
Graphic 
Alignment
5-5



Chapter 5: Using graphics and image maps
3 From the Edit menu, select Properties, then choose Image 
Properties. Or, click the Object properties toolbar button. The 
Image Properties dialog box appears, as shown below.

4 Use the options in the Image Properties dialog box to set the 
graphic’s attributes. These attributes are described in the table 
below.

5 Click OK. Your graphic’s settings are adjusted accordingly.

Attribute Description

Image The location and filename of the image file.

Width The display width of the image, in pixels.

Visual Page supports image scaling (changing 
an image's height and width). The width and 
height indicated in the Image Setting dialog 
box are the dimensions of the image as 
scaled in the HTML file. The actual 
dimensions of the image are indicated in the 
Original Width and Original Height fields, as 
described below.

Height The display height of the image, in pixels.

Original width The width of the source image, in pixels.

Original Height The height of the source image, in pixels.
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Creating transparent graphics
Transparent graphics are images whose background color is clear, allowing 
the color of the Web page that the graphic is placed in to show through. 
Making the background color of a graphic file transparent is a useful 
technique when you want the image to appear as if it's embedded in the 
page. 

Note: Only image files in the GIF format can be made transparent.

Horizontal The blank space to the left and right of the 
image, in pixels. The default setting is zero.

Vertical The blank space to the top and bottom of the 
image, in pixels. The default setting is zero.

Border Width The width of the border around an image, in 
pixels. An image border is black and is 
similar to a frame around a painting. 

The default setting is zero, which indicates 
no border.

Image Select this option if the graphic file functions 
only as an image. This is the default function 
for graphic files.

Has server map Check this box if the graphic file acts as a 
server-side image map. For more information 
on image maps, see “Creating and editing 
image maps” on page 5-13.

Submit form button Select this option if the graphic file acts as 
submit button for a form. For more 
information on forms, see “Creating forms” 
on page 7-9.

Alternative text If you type in text here, it displays in a user's 
browser if the image doesn't load properly, 
or if it can't be displayed by a user's browser. 

Note: The alternative text option is not for 
graphic files that function as a form submit 
button.

Attribute Description
5-7



Chapter 5: Using graphics and image maps
To make an image transparent:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Open the graphic by double-clicking on the file in the Local Site 
window, or choose Open from the File menu and open the image 
from the Open dialog box. 

The graphic appears in Visual Page's main editing window, as shown 
below:

3 Right-click on the image. A menu appears.

4 Select Edit Transparency/Interlace. The image appears in its own 
window, and the Image Tools toolbar displays.

5 Select the transparency color button in the Image Tools toolbar. 

6 Click on any area of the image which contains that the color that 
you want to be transparent. The area’s color changes to white.

7 Save the file by choosing Save from the File menu.

When the altered graphic is dropped into a Web page, you will see the 
background of the page in all the places the selected color filled before. .
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Creating interlaced images
When your Web pages are downloaded by a user’s browser, images usually 
appear one pixel-high line at a time. Another way of having the files 
download is by making them interlaced. Interlaced images download as 
first a general outline of the image, and then as more image data is 
received by the browser, the details of the image come into view. Viewing 
it is much like seeing a picture come into focus, and can be more 
interesting to a user. Be aware that interlaced images are slightly larger 
than regular image files, so this will affect download time as well. For more 
information about download time of images, see “Calculating file 
transmission times” on page 8-9.

To create an interlaced image:

1 Open your Web page.

2 Make sure that you’re in Edit mode. To go to Edit mode, click the 
Edit Page toolbar button.

3 Right-click on the image you want to be interlaced. A menu 
appears.

4 Select Edit Transparency/Interlace from the menu. The image 
opens in its own window, and the Image Tools toolbar displays.

5 Click the Image Interlace button. The image is now an interlaced 
image.

6 Select Save from the File menu to save your changes.

Creating tiled backgrounds
Instead of using a colored or plain background behind your Web page, 
you may choose to add a tiled background — tiled backgrounds can add a 
striking visual motif to your Web pages. Visual Page provides an easy-to-
use graphic interface for doing this. 

To create a tiled background for your Web page:

1 Open your Web page. 
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2 Click the Page Properties button in the toolbar. 

The Page Properties dialog box appears, as shown below.

3 Click the Background Image checkbox. An Open File dialog box 
appears. If you are changing the background image, click the 
browse directory button (shown at left). 

4 Navigate to the graphic file you're going to use, then click Open.

Click 
here
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A reduced-size version of the graphic appears in the Background 
Image subwindow, as shown below:

5 Check the appearance of the tile on your page by clicking the 
Apply button. A graphic may look interesting by itself, but may be 
too overpowering to use as a tiled background, as shown below.

6 To try another background tile, click the browse directory button 
on the old image, then repeat steps 3-5. To remove a background 
image, deselect the Background Image checkbox.

7 When you're satisfied with the background, click OK to display it 
on your Web page.
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Creating lines
Visual Page lets you add horizontal lines to your Web pages. Lines can be 
used to break up the sections of a Web page, so that the Web page 
becomes easier to read.

Inserting a line

To add a line:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place your cursor where you want the line to be inserted.

3 Click the Insert Line toolbar button. A horizontal line appears in 
the Web page.

Setting a line's attributes

To set a line's attributes:

1 Select a line by single-clicking it.

2 From the Edit menu, select Properties, and choose Line Properties. 
The Line Properties dialog box appears.
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3 Use the attributes in the Line Properties dialog box to set the rule’s 
attributes. These attributes are described in the table below.

4 Click OK. The horizontal line displays accordingly.

Note: The alignment attribute overrides the alignment of the line's 
paragraph. For example, if the line is center aligned and the line’s 
paragraph is set to left alignment, the line becomes left-aligned.

Creating and editing image maps
Unlike a block of text, an image can have more than one link associated 
with it. An example of such an image might be a picture of a map where 
each name on the map is linked to additional information about that map 
location. An image used to contain multiple linked areas is called an image 
map. 

Visual Page supports two types of image maps: client-side and server-
side.

After you finish creating or editing your image map, you may want to 
check the links in your image map in Preview mode. For information on 
the Preview mode, see “Previewing your work” on page 2-17. For details 
on testing and fixing links, see “Testing and fixing links and anchors” on 
page 4-9.

Attribute Description

Width Width of the line, in pixels or as a 
percentage of the line's container width (a 
table cell or the whole Web page). 

Height Height of the line, in pixels.

Alignment Alignment of the line (left, center, or right).

3D Shading Indicates whether or not to apply 3D 
shading to the line. The default is selected, 
which indicates that the line is shaded.
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Creating client-side image maps

Client-side image maps store the coordinates that define the clickable areas 
of an image map within the HTML file. As such, the image map can be 
downloaded to a user’s browser and referenced entirely from the user’s 
machine (hence the name client-side). For a client-side image map to work 
properly, it must be within an HTML file.

To create a client-side image map:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button.

2 Open or create a new Web page.

3 Insert a graphic by clicking the Insert Graphics icon in the toolbar. 
For information on inserting graphics, see “Inserting a graphic” on 
page 5-2.

4 Right-click on the graphic. A menu appears.

5 Select Local Map Tools from the menu. 

The Image Tools toolbar displays.

6 Create the clickable areas of the image by doing the following:

a Click either the rectangle, circle, or polygon Hotspot buttons on 
the Image Tools toolbar. 

b To end creating a polygon hotspot, double-click. To end creating 
a circle or rectangle hotspot, simply release the mouse button. 

c Click and drag on the graphic file to create a hotspot area.

d (optional) To make the shapes easier to see, specify the color of 
these areas by choosing the desired color from the color menu 
button.

e (optional) You may also use the Zoom buttons to adjust the 
graphic to the optimal size for outlining links. 

f Create the URL for each of the clickable areas. You can do this by 
either dragging a file or anchor icon from the Local Site window 
onto the selected link area, typing the link address into the Link 
To field at the bottom of the main edit window, or right-clicking 
on the desired link location to open the Link dialog box. 

g To delete hotspot areas, select the hotspot area, and press Delete.

7 To save your client-side image map, select Save from the File 
menu. 
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Creating server-side image maps

Visual Page also supports creation of server-side image maps. While 
Symantec recommends using client-side image maps, if your Web server or 
browser software doesn’t support client-side image maps, you may want to 
use this feature.

Before you create the server-side image map, first set the image map file 
format.

Note: Before you start creating a server-side image map, check with your 
System Administrator or Internet Service Provider (ISP) as to whether your 
Web server supports image map files in the CERN or NCSA format, and if 
your Web server requires a header in the image map’s .map file (the file 
that contains the image map’s coordinates).
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To set the image map file format:

1 From the Edit menu, select Preferences. The Preferences dialog 
box opens., as shown below.

2 Select the Images tab, as shown below.

3 Select the image map format that you want: CERN or NCSA.

4 Click OK.

To create a server-side image map:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button.

2 Open or create a new Web page.

3 Select a graphic within the Web page by clicking once anywhere 
in the image. If you have not included the graphic in the Web 
page, see “Inserting a graphic” on page 5-2.

4 Right-click on the image. A menu appears.
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5 Select Edit Server Side Map. The graphic file opens in its own 
window, and the Image Tools toolbar displays.

6 Use the Image tools (rectangle, circle, polygon) to outline the parts 
of the image you want to use as links. 

7 (optional) To make the shapes easier to see, specify the color of 
these areas by choosing the desired color from the color menu 
button.

8 To create a link, drag a file or anchor icon onto the selected link 
area, or type the URL into the Link To field at the bottom of the 
main edit window.

9 Once you have inserted the links for your image map, save it by 
choosing Save from the File menu. 

Once the image map is saved, Visual Page generates the image map’s 
.map file, and places it in the same folder as your image file.

To activate a server-side image map, you need to upload the image and its 
.map file to a Web server. Contact your System Administrator or Internet 
Service Provider for more details.

What’s next

In the next chapter, we explore Visual Page’s tools for creating and 
manipulating frames and tables.
5-17



Chapter 5: Using graphics and image maps
5-18



C H A P T E R 6
Creating frame sets and 
tables

This chapter covers the range of tools that Visual Page provides for the 
creation and editing of frame sets and tables, including resizing and 
splitting of frames, insertion and deletion of rows and columns, resizing of 
tables, and selection/manipulation of multiple cells.

Creating frame sets
A frame set consists of two or more independent parts (called frames). 
All frames contain a single HTML file within its borders — as such, a frame 
set is essentially a Web page that contains multiple Web pages. Frames can 
be scrolled, resized, or have their contents replaced dynamically. 
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An example of a frame set is shown below. 

To create a frame set:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Choose New Frame Set from the File menu (or press Shift-Ctrl-N). 
A frame set with two frames of equal size displays.
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3 Choose Save Frame Set from the File menu (or press Ctrl-S). The 
Save As dialog box appears.

4 Navigate to the folder where you want to save the main frame, 
enter a name for the frame set, and click Save.
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Now that you’ve got your frame set started, you can add text (see Chapter 
3 for details), insert graphics (as explained in Chapter 5), tables (see 
Chapter 6 for details), and advanced features — such as plug-ins, Java 
applets, JavaScript code, or forms (described in Chapter 7). If you want to 
preview your document, or view its HTML source code, be sure to see the 
sections covering preview and source code modes in Chapter 2.

When you save your frame set again, you’ll be prompted to save the Web 
pages within your frame set:

1 Choose Save Frame Set from the File menu. A Save Frame As 
dialog box displays, allowing you to save the left hand frame file. 

Enter a name for the frame file and click Save. A second file save 
dialog box displays, this time for saving the right hand frame file. 

Click 
here
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2 Enter a name for the frame file and click Save.

While it is possible to save the Web pages in the left and right-hand frames 
to a different location than the frame set, it will be easier for you to track 
and maintain all three files if they are in one folder, with similar names. For 
example, you may want to name the frame set main.html, the Web page 
in the left-hand frame lframe.html, and the Web page in the right-hand 
frame rframe.html.

After you finish creating your frame set, you may want go into Preview 
mode, in order to see how your frame set looks. For details on using the 
Preview mode, see “Previewing your work” on page 2-17.

Click 
here
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Changing a frame's Web page

Visual Page lets you replace the Web page contained within a frame with 
another Web page. You can use this to insert an existing Web page, if you 
want.

To change the Web page displayed in a frame:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the frame to be replaced by single-clicking anywhere within 
the frame.

3 Choose Set Frame Source from the Frame menu. An Open dialog 
box appears.

4 Navigate to and select the new file that will display in the frame.

5 Click Open. Visual Page displays the new Web page inside the 
frame.

Displaying a frame-based Web page in its own window

Visual Page allows you to display the Web page contained within a frame 
in its own window. This can be useful when you want to edit the frame 
file, but have more space to work in.
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To open a frame-based Web page in its own window:

1 From the main editing window, select a frame file by single-
clicking anywhere within a frame in a frame set.

2 Choose Open in New Window from the Frame menu.

The Web page opens in its own window.

Setting a frame's attributes

Visual Page supports a range of attributes that are contained within any 
frame. 

To set a frame's attributes:

• Choose Properties > Show Frame Properties from the Edit menu. 
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The Frame Properties dialog box displays, as shown below:

3 Use the options in the Frame Properties dialog box to set the 
frame’s attributes. These attributes are described in the table 
below.

4 Close the Table Properties dialog box by clicking on the close 
button (an X in the upper-right corner).

The frame attributes are defined below:

Attribute Definition

Source The HTML source file for a frame.

Frame title The frame's name. This is NOT the same as 
the name of the source file. The frameset file 
(the file that contains the frames within a 
frame set) uses this name as an ID.
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Modifying frames

Visual Page has several features for modifying frames, including changing a 
frame’s size, removing a frame from a Web page, and splitting a frame into 
two sections.

Changing a frame's size

Resizing of a frame is controlled with the resize bar (shown at left). The 
resize bar appears automatically when you place the cursor over a frame 
while in Edit mode.

To resize a frame:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Adjust the frame’s size with the resize bar, or choose Show Frame 
Properties from the Edit menu and enter the desired width in the 
Width field.

Frame width The width of the selected frame, either as a 
percentage of the total frame set, or in pixels.

Frameset height The height of the frame set, either as a 
percentage of the total frame set, or in pixels.

Margin width The width of the selected frame's margin, in 
pixels.

Margin height The height of the selected frame's margin, in 
pixels.

Show scrollbar The settings for the frame's scroll bars. 
Possible choices are Yes, No, and Auto. The 
default is Auto, which makes the scroll bars 
appear only when the frame extends beyond 
the length of the active window.

Resizable frame Indicates whether or not the selected frame 
resizes along with the user's browser. The 
default is checked, which indicates that the 
selected frame will resize.

Attribute Definition
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For more information about the Width field, see “Setting a frame's 
attributes” on page 6-7.

Removing a frame

Visual Page lets you remove a frame from within a frame set.

Note: Removing a frame doesn't delete the frame file contained within the 
frame, only the frame itself.

To remove a frame:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the frame to be removed.

3 Choose Remove Frame from the Frame menu. The frame 
disappears from the frame set.

Splitting frames

Visual Page lets you split a frame into two equal parts, either horizontally 
or vertically.

To split a frame:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the frame to be split.

3 Choose either Split Frame Vertically or Split Frame Horizontally 
from the Frame menu. The frame divides accordingly into two 
frames.

Using the No Frames window

The No Frames window lets you specify what to display when a user's 
browser doesn't support frames. This lets the content of your Web files still 
be viewed by users, even when their browsers don’t support frames.

To use the No Frames window:

1 Open a frame-based Web page.
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2 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

3 Choose No Frames Page from the Frame menu. The No Frames 
dialog box displays.

4 Enter the content to be displayed.

5 Close the No Frames window. 

6 From the File menu, choose Save Frame Set. Your No Frames 
information is saved.

To view or edit content that you've entered into the No Frames window, 
choose No Frames Source from the Frame menu. The No Frames window 
appears, letting you edit the No Frames contents.

Setting the frame target

Visual Page provides a feature that you can use to select a base target for 
all the links in a frame. A base target is the frame in which a linked file 
displays. For instance, you could use this feature to direct all the hypertext 
links in a left-hand frame to appear in the neighboring right-hand frame. 

To set a base target for the links in a frame:

1 Open a frame set, and make sure the frame is already named and 
saved.

2 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

3 Select a frame by single-clicking in it. 
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4 Select the Properties from the Edit menu, and choose Page. The 
Page Properties dialog box displays, as shown below. 

Click 
here
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5 Click the Select Base Target button. The Base Target dialog box 
opens, as shown below.

6 Click a frame in the reduced-size version of your frame set. Set a 
base target for that frame by selecting one of the Base Target 
options. The Base Target options are described below.

Base Target option Description

Default Makes the linked file display in the same 
frame as the current frame file. This is the 
default setting. How the default setting 
performs depends on each browser’s 
configuration.

New window Makes the linked file display in a new, 
untitled window.

Same frame Makes the linked file display in the same 
frame as the current frame file.

Same window Makes the linked file display in the same 
window as the current frame file.
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7 (optional) If you want to set the base target for another frame in 
your frame set, go through step 6 again for each frame.

8 Click OK to set the base target for the selected frame. 

Creating tables
Like frames, tables increase the design options for Web-based content. 
Unlike frames, tables display content in a grid-based format, allowing 
control over single elements within the table jcells), as well as the 
formatting of the entire table. This section covers how to format and 
modify tables, including inserting tables, editing single cells, multiple cells, 
and entire tables, and setting of attributes for tables and their cells.

After your table is inserted and formatted, you can go into Preview mode 
to see how it looks. For information on using the Preview mode, see 
“Previewing your work” on page 2-17. 

Inserting tables

To add a table to your Web page:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Position the insertion point where you want the table to appear. 
You position the insertion point by putting your cursor in the 
desired location, and clicking once.

Parent window Makes the linked file display in the parent 
window of the current frame file. The parent 
window is the window that was active, then 
a link opened which caused the current 
frame file to display.

Base Target option Description
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3 Click the Insert Table toolbar button (shown at left). The Table 
Properties dialog box displays, as shown below:

4 Set the number of rows and columns for your table. For 
information about setting attributes for a table, see “Setting table 
attributes” on page 6-21.

5 Close the Table Properties dialog box by clicking on the close 
button (an X in the upper-right corner). 

Editing tables

Visual Page provides an extensive set of tools for the editing of tables in 
your Web pages, including multiple cell selection and editing, insertion 
deletion, and resizing of rows and columns, and spanning of rows and 
columns.
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Selecting and editing multiple cells

Visual Page allows selection and editing of multiple adjacent cells. 

To select multiple cells:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select a set of multiple adjacent cells, as shown below.

Perform the editing task or tasks that you want to execute on the selected 
cells. Any selected set of cells may have the following changes applied to 
them:

n Paragraph formatting (see “Formatting paragraphs” on page 3-3 
for more information)

n Paragraph alignment (see “Aligning paragraphs” on page 3-8 for 
more information)

n Character formatting (see “Formatting characters” on page 3-8 
for more information)

n Deleting multiple rows or columns (see “Deleting rows and 
columns” on page 6-17 for more information)

n Setting cell attributes (see “Setting cell attributes” on page 6-23 
for more information)

Inserting rows and columns

Visual Page supports insertion of rows and columns into existing HTML 
tables. 
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To insert a row into a table:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place the cursor where you want the row to be inserted in the 
table. 

3 Click the Insert Row button in the main toolbar. A new row 
appears above the current row.

To insert a column into a table:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place the cursor where you want the column to be inserted in the 
table.

3 Click the Insert Column button in the main toolbar. A new column 
appears to the left of the current column.

Deleting rows and columns

Visual Page supports the deletion of rows and columns from existing 
HTML tables. 

To delete a row from a table:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place the cursor anywhere within the row to be deleted, or select a 
set of rows to be deleted.

3 Click the Delete Row button in the main toolbar. The rows 
disappear.

To delete a column from a table:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place the cursor anywhere within the column to be deleted, or 
select a set of columns to be deleted.

3 Click the Delete Column button in the main toolbar. The columns 
disappear.
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Spanning rows and columns

You can use Visual Page to extend a cell across a number of rows or 
columns. This allows you to create tables with asymmetrical cell 
placement, such as a cell that spans two rows and two columns. 

To set a cell to span across multiple rows and/or columns:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Click on the cell that you want to enlarge.

3 From the Edit menu, select Properties, then choose Table 
Properties. The Table Properties dialog box displays.

4 Click on the Cells Tab.

5 Within the Span across columns field, enter the number of 
columns that you want the cell to span.

6 Within the Span down rows field, enter the number of rows that 
you want the cell to span.

7 Close the Table Properties dialog box by clicking on the close 
button (an X in the upper-right corner).

An example of a table with a spanned cell is shown below.

Resizing rows and columns

You can resize one or more rows and columns within Visual Page. 

To resize a row or column:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place the pointer over the border of the row or column you want 
to resize. The pointer changes to a resizing cursor.
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3 Click on the row or column's border and hold the mouse button 
down.

4 Drag the mouse until the row or column is resized to the desired 
dimensions.

5 Release the mouse button. The row or column remains according 
to the revised dimensions.

Resizing tables

In addition to resizing rows and columns, you can resize an entire table. 

To resize a table:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select the table to be resized by clicking anywhere within the 
table.

3 Click on a resizing handle (the square boxes that appear around 
the edge of the table) and hold the mouse button down.

4 Drag the mouse until the table is resized.

5 Release the mouse button.

Adding color to tables

You can use Visual Page to set the background color of an entire table or 
the background color of one or more cells. This can be used to distinguish 
individual subsections (groups of cells) within a row or column, for 
example.

To change a table's background color:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select a table by clicking anywhere within the table.

3 From the Edit menu, select Properties, and then choose Table 
properties. The Table Properties dialog box appears, as shown 
below:
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For more information about the Table Properties dialog box, see 
“Setting table attributes” on page 6-21.

4 Click the Table tab.

5 Click the Background Color button. A color palette appears.

6 Select the color you want from the color palette. 

If you want a custom color, click Custom and create your color by 
clicking in the color box or by setting the Hue, Saturation, 
Lumination, and Red, Green, Blue amounts. Once you’ve created the 
desired color, click the Add to Custom Colors button, and your 
custom color is added to the Custom colors palette area.

7 When you’ve chosen the color you want, click OK.

Click 
here
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To change a cell's background color:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select one or more cells.

3 From the Edit menu, select Properties, and then choose Table 
properties. The Table Properties dialog box appears. 

For more information about the Table Properties dialog box, see 
“Setting table attributes” on page 6-21.

4 Click the Cells Tab.

5 Click the button next to Cell background color. A color palette 
appears.

If you want a custom color, click Custom and create your color by 
clicking in the color box or by setting the Hue, Saturation, 
Lumination, and Red, Green, Blue amounts. Once you’ve created the 
desired color, click the Add to Custom Colors button, and your 
custom color is added to the Custom colors palette area. Click OK to 
close the color palette.

6 Click on the color you want. The color palette closes.

7 To close the Table Properties dialog box, click on the close button 
(the X in the upper-right corner).

Setting table attributes

Visual Page supports a range of table attributes, including the number of 
rows and columns as well as row and column dimensions. 

To edit a table's attributes:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select a table by clicking anywhere within the table.
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3 From the Edit menu, select Properties, and then choose Table 
properties. The Table Properties dialog box appears, as shown 
below:

4 Click the Table tab to display the attributes for the entire table. For 
information on setting attributes for individual cells, see “Setting 
cell attributes” on page 6-23. These attributes are described in the 
table below.

5 Close the Table Properties dialog box by clicking on the close 
button (an X in the upper-right corner).

Attributes Description

Number of rows The number of rows in the table.

Number of columns The number of columns in the table.

Space around text The margin around a cell’s text, in pixels.
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Setting cell attributes

Note: Except for Span Rows and Span Columns, all of the settings below 
apply to multiple cell selection as well as to selection of individual cells.

Visual Page supports a range of features for individual cell manipulation, 
such as cell dimensions and cell background color. 

To edit a cell's attributes:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select a cell or range of cells within a table. 

Space between cells The margin between each cell, in pixels.

Width The width of the selected table. This value is 
either a percentage of the total container 
width (a window, frame or another table 
cell), in pixels, or is set automatically by 
Visual Page. When set to auto, Visual Page 
adjusts the width in proportion to the table's 
content.

Table's height The height of the selected table. This value is 
either a percentage of the total container 
height (window or frame), in pixels, or is set 
automatically by Visual Page. When set to 
auto, Visual Page adjusts the height in 
proportion to the table's content.

Border width The width of the table's border, in pixels. A 
setting of 0 indicates no border.

Caption placement The caption above or below the table's 
body. The default is set to None, indicating 
that the table doesn't have a caption.

Background color The background color of the table. The 
default is for no color to display. For more 
information, see “Adding color to tables” 
on page 6-19.

Attributes Description
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3 From the Edit menu, select Properties, and then choose Table 
properties. The Table Properties dialog box appears. 

4 Click the Cell tab to display the attributes for the selected cells, as 
shown below:

5 Use the cell options displayed in the Cell Properties dialog box to 
set the attributes of the selected cell(s). These attributes are 
described in the table below.

6 Close the Table Properties dialog box by clicking on the close 
button (an X in the upper-right corner).

Attributes Description

Row and column dimensions
6-24



Creating tables
What’s next

In the next chapter, we cover Visual Page’s advanced features — inserting 
plugins and Java applets, using JavaScript, and incorporating forms into 
your Web pages.

Width The width of the selected cells’ column, 
either as a percentage of the table's width, in 
pixels, or as set automatically by Visual Page. 
When set to auto, Visual Page adjusts the 
width in proportion to the column's content.

Height The height of the selected cells’ row, either 
in pixels or as set automatically by Visual 
Page. When set to auto, Visual Page adjusts 
the width in proportion to the row's content.

Span across columns Spans the cell across the indicated number 
of columns. Default is set to 1. For more 
information, see “Spanning rows and 
columns” on page 6-18.

Span down rows Spans the cell across the indicated number 
of rows. Default is set to 1. For more 
information, see “Spanning rows and 
columns” on page 6-18.

Vertical alignment The vertical alignment of the selected cell's 
contents. The default is to align the cell's 
contents in the vertical center of the cell.

Header style Indicates whether or not to apply the Header 
table tag (centered bold format) to the active 
cell's contents. The default is set to 
unchecked, indicating that the header style is 
not applied.

Wrap lines Indicates whether or not to apply line 
wrapping to the selected cell's contents. 
Default is set to checked, indicating that line 
wrapping is applied.

Background color The color of the selected cell(s). The default 
is for no color to display. For more 
information, see “Adding color to tables” 
on page 6-19.

Attributes Description
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C H A P T E R 7
Advanced features

This chapter covers the advanced features of Visual Page, including placing 
plugin media and applets into your Web pages, integrating JavaScript with 
your Web pages, creating forms with Visual Page, and integrating CGI 
scripts with your forms.

Inserting plugins and applets
Visual Page provides integrated support for plugins and applets — placing 
audio, video and streaming media (audio, video, or graphics that have 
been optimized for fast transmission across the Web) is effortless. 

Be sure to preview your Web page after inserting a plugin or applet, to 
ensure that the plugin or applet is placed properly in the page. For details 
on using the Preview mode, see “Previewing your work” on page 2-17.

Inserting plugins

To insert a plugin:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Position the insertion point by placing the cursor over the desired 
insertion point and single-clicking.

3 In the toolbar, click the Insert PlugIn button.

4 Navigate to and select the plugin file that you want to insert.

5 Click OK. The plugin is now inserted.
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You can also drag and drop plugins from the Local Site window, if your 
global preferences are set to display all files from within the Local Site 
window. For information about setting the global preferences, see “Setting 
the global preferences” on page 2-6.

To drag and drop a plugin:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Open a Local Site window for the folder that contains the plugin 
by selecting Open Local Site from the File menu. For information 
on setting up your Local Site window, see “Setting up your local 
Web site” on page 2-12.

3 Within the Local Site window, select the filename for the plugin by 
clicking it once. 

4 Drag the selected plugin from the Local Site window to the Web 
page, and release the mouse button where you want the plugin to 
appear.

The plugin appears in the Web page.

Setting plugin attributes

To modify a plugin’s attributes:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 
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2 Double-click on the plugin. The Plugin Properties dialog box 
appears, as shown below.

3 Use the options in the Plugin Properties dialog box to set the 
plugin’s attributes. These attributes are described in the table 
below.

4 Click OK.

Attribute Description

Location The folder containing the plugin.

Name The name of the plugin. 
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Note: The creation and editing of plugin content needs to be done within 
the appropriate plugin utility and/or pertinent software packages. 

Inserting applets

To insert an applet:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Position the insertion point where you want the plugin to appear. 
Do this by placing the cursor over the desired insertion point and 
clicking the mouse button once.

3 Click the Insert Java Applet toolbar button (shown at left).

4 Navigate to and select the applet file that you want to insert.

5 Click OK. The applet is now in your Web page.

Note: Applets run only in the Preview mode. 

You can also drag and drop applets from the Local Site window, if your 
global preferences are set to display all files from within the Local Site 
window. For information about setting the global preferences, see “Setting 
the global preferences” on page 2-6.

Width The width of the plugin, in pixels.

Height The height of the plugin, in pixels.

Horizontal Space around The horizontal blank space around the 
plugin, in pixels.

Vertical Space around The horizontal blank space around the 
plugin, in pixels.

Parameters Customized parameters of the plugin (if 
any), and their respective values.

Attribute Description
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To drag and drop an applet:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Open a Local Site window for the folder that contains the plugin 
by selecting Open Local Site from the File menu. For information 
on setting up your Local Site window, see “Setting up your local 
Web site” on page 2-12.

3 Within the Local Site window, select the applet file by clicking the 
file’s icon. 

4 Drag the selected applet from the Local Site window to the Web 
page, and release the mouse button where you want the applet to 
appear. The applet is now part of your Web page.

Setting applet attributes

To modify the parameters of an applet:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 
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2 Double-click on the applet. The Java Applet Properties dialog box 
appears, as shown below:

3 Use the options in the Applet Properties dialog box to set the 
applet’s attributes. These attributes are described in the table 
below.

4 Click OK.

Attribute Description

Location The folder containing the applet.

Name The name of the applet. 
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Note: For information on creating custom parameters, consult the Java 
documentation for the applet class.

Visual Page's Java console

If your Web pages include Java applets, you may need to use the Java 
console. The Java console is commonly used as the output window for a 
Java applet — when you run an applet in Visual Page, the place that 
runtime output commonly displays is in the Java console.

To access the Java console:

• Choose Show Java Console from the View menu. 

Visual Page and Visual Cafe

Symantec’s Visual Cafe is an ideal complement to Visual Page for creating 
Web-based content. Visual Cafe includes several features that are useful to 
creating Web-based Java content, including full applet creation support, an 
easy-to-use graphical interface, and wizards for creating interactive content.

Using JavaScript
Netscape’s JavaScript protocol is designed for the creation of interactive 
Web pages. By integrating JavaScript code into a Web page, you can create 
pages that are designed according to a user’s specifications, storage and 

Width The width of the applet, in pixels.

Height The height of the applet, in pixels.

Horizontal Space around The horizontal blank space around the 
applet, in pixels.

Vertical Space around The horizontal blank space around the 
applet, in pixels.

Parameters Customized parameters of the applet (if 
any), and their respective values.

Attribute Description
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retrieval of user-based data, and a variety of other basic programming-level 
tasks. 

Note: Not all browsers support JavaScript. For details, consult the 
documentation for any browsers you plan on supporting in your Web site.

Adding JavaScript to a Web page

JavaScript code can be imbedded directly into a Web page. This cuts down 
on the overhead of maintaining a separate file for the JavaScript code.

To insert JavaScript code into a Web page:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Select JavaScript from the Style menu.

3 Enter your JavaScript code. 

Visual Page changes the color of the text to indicate that it’s 
JavaScript.

4 Deselect JavaScript from the Style menu.

Visual Page inserts the beginning and ending HTML script tag (</
SCRIPT>) around the selected block in the Web page source code, as 
seen in the source editor.

Once you've entered the requisite Javascript tags into your Web page, you 
can edit the Javascript code in Visual Page's source editor. For details on 
using the source editor, see “Viewing the HTML code” on page 2-17. 

After you finish inserting your JavaScript code, you can use the Preview 
mode to view and test the results of your JavaScript code. For information 
on using the Preview mode, see “Previewing your work” on page 2-17. 

Accessing a stand-alone JavaScript file

Saving your JavaScript codes and calling them from a Web page as you 
need them enables you to reuse JavaScript routines. For example, if you 
have a banner script that you'd like to reuse on other pages, you can save 
the JavaScript code as a separate file, and access it as you wish, without 
having to cut and paste the code into a Web page every time. To guarantee 
that Visual Page can find your JavaScript files, make sure that they end with 
a .js extension.
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While this method increases your file maintenance overhead, it also makes 
your code accessible from any Web page, without having to paste the 
JavaScript code into a Web page.

If you create a stand-alone JavaScript file, note that it is saved in a plain 
text (ASCII) format; as such, it can be uploaded and downloaded in the 
same manner as any other text file. For information on uploading and 
downloading text files, see “Uploading files to your Web server” on page 8-
4 and “Downloading files from your Web server” on page 8-6.

To call a JavaScript file from within a Web page:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place the cursor where you want the JavaScript call to occur.

3 Choose JavaScript file from the Insert menu. The Open dialog box 
displays, listing all of the files with a .js extension. 

4 Navigate to the folder containing the JavaScript file that you want 
to use, and select the desired JavaScript file.

5 Click Open.

Visual Page inserts a JavaScript icon into the Web page, along with a pair 
of <SCRIPT> tags in the Web page’s HTML source, using the following 
format:

<SCRIPT LANGUAGE "JavaScript" SOURCE="symantec.js"></
SCRIPT>

Creating forms
Forms are used for the creation of HTML-based input and processing of 
data. If you’ve ever registered for a piece of software on the Web, you’ve 
used forms: the fields that you enter your name, phone number, and email 
address into are all parts of a form. 

Note: Be sure to preview your Web page after inserting a form, to ensure 
that it is placed properly within the page. For details on using the Preview 
mode, see “Previewing your work” on page 2-17.
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Adding form elements to a Web page

Forms are created by including one or more form elements (such as fields 
and checkboxes) as part of a form structure. Visual Page includes this form 
structure for you. All you need to do is place the elements in a Web page.

Visual Page supports the standard user interface elements used in forms, 
such as radio buttons, checkboxes, and input fields.

To add a form element to a Web page:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Position the insertion point where you want the form element to 
appear. Do this by placing the cursor over the desired insertion 
point and clicking the mouse button once.

3 Choose Form Item from the Insert menu. A list of form elements 
displays. You can also select Toolbars > Form Tools from the View 
menu to display the Form Tools toolbar, as shown below. 

4 Select the desired form element, or click its button in the toolbar.

When you insert a form element, Visual Page inserts the required 
<FORM> tag, along with the form element. This automatically creates 
the structure for a form.

Using CGI

CGI scripts and applications pass information from your forms to your Web 
server. CGI scripts can be written in any computer or scripting language — 
some of the more common languages used for CGI scripting include Perl, 
C and C++.

In most cases, you’ll want to use an existing CGI script or application. You 
can obtain CGI scripts and applications either from your System 
Administrator, or from a number of shareware and freeware CGI script 
archives on the Internet, including the following:

http://www.cis.ufl.edu/perl/
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http://www.seas.upenn.edu/~mengwong/perlhtml.html

For further information, Web sites with information on CGI include: The 
General CGI Web site at http://www.selah.net/cgi.html, and the 
Perl archive at http://www.perl.com/perl/.

To access an existing CGI item on your local hard drive:

1 Choose Properties>Form from the Edit menu. The Form Properties 
dialog box displays, as shown below:

2 Enter the path and name of your CGI script or application in the 
Action field.

3 Select the type of method your CGI item uses: post or get. The get 
method sends the user's information as part of the URL, while the 
post method sends it as a separate data stream.

4 Click OK. Visual Page inserts the proper HTML codes for your Web 
page to interact with your designated CGI item.

Inserting multiple forms

Visual Page allows you to have multiple forms within a single Web page. 

To insert multiple forms:

1 If you’re not in Edit mode, switch to this mode by clicking the Edit 
Page toolbar button. 

2 Place the cursor where you want a new form to be inserted.

3 Choose Form Item from the Insert menu. A pop-up menu appears.

4 Choose Extra Form. The Form Properties dialog box displays.

5 Enter the path and name of your CGI item in the Action field.
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6 Select the type of method your CGI item uses: post or get.

7 Click OK.

The Form icon appears, indicating the extra form.

What’s next

In the next chapter, we examine Visual Page’s Web site maintenance 
features, including FTP support, file transmission calculation, and folder 
mapping.
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Managing and maintaining 
your Web site

As mentioned in “What is FTP?” on page 1-8, in order for people to have 
access to your Web-based files (Web pages, GIF graphics, plugins, and so 
on), you need to put them on a Web server. Visual Page has several tools 
to assist you in the process of placing your Web files onto a Web server, 
such as an upload/download interface, Web site maintenance tools, and 
file transmission calculator. This chapter explores these tools in depth, and 
shows how you can use these tools as part of your strategy for Web site 
management.

Setting up your network connection
Visual Page allows you to configure default settings for your Web server, 
including server name, password, and user ID. 
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To configure your default network settings:

1 Choose Preferences from the Edit menu. The Preferences dialog 
box displays, as shown below.

2 Choose the Network tab, as shown below.

3 Enter the host name of your Web server in the Default FTP host 
field (for example, ftp.symantec.com).

4 If you are going to a subdirectory within your home directory, 
enter it in the Default FTP directory field. In most cases, the server 
defaults to your home directory as your destination — if this is the 
case, you can leave this field blank.

5 If the site you're accessing requires a user name, enter the user 
name or ID for your account in the Default user name field (for 
example, JQPublic).

6 If the site you're accessing requires a password, enter the 
password for your account in the Default password field.
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Connecting to your Web server
The first step in using Visual Page to transfer your Web files is to establish 
a connection to your Web server. This allows you to upload and download 
files, as well as perform file management tasks for your Web site (such as 
deleting obsolete or unneeded files).

Visual Page uses the File Transfer Protocol (FTP) to connect to Web 
servers, and to transfer files from and to a Web server once connected.

Note: If you are logging into your default server as specified in the 
Network preferences, you can skip steps 2-5. For more information, see 
“Setting up your network connection” on page 8-1.

To establish a connection to your server:

1 From the File menu, choose Open FTP Site. The Open FTP Site 
dialog box displays, as shown below.

2 Enter the host name of your Web server in the Default FTP host 
field (for example, ftp.symantec.com).

3 If you are going to a subdirectory within your home directory, 
enter it in the Default FTP directory field. In most cases, the server 
defaults to your home directory as your destination — if this is the 
case, you can leave this field blank.

4 If the site you're accessing requires a user name, enter the user 
name or ID for your account in the Default user name field (for 
example, JQPublic).
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5 If the site you're accessing requires a password, enter the 
password for your account in the Default password field.

6 Click OK. Visual Page connects you to your Web server and 
displays the FTP Site Window, as shown below: 

The FTP Site Window is the remote counterpart to the local Site Window 
for your Web server. You use the FTP Site Window to upload, download, 
and maintain the files that make up your Web site. 

Note: If you don't know your user ID and/or password, or are unable to 
connect to your Web server, contact your ISP or System Administrator for 
your network for further information.

Uploading files to your Web server
To place your Web files on a Web site, you need to upload them. There are 
two types of files that you can upload to the Web:

• Text files (also known as ASCII files) are the default format for 
Web pages in Visual Page, and are the universal standard for 
HTML files.

• Binary files are commonly graphics (such as GIF and JPEG images) 
and other types of media (such as Shockwave and QuickTime 
movies).
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Note: When uploading your files, be sure to differentiate between local 
storage (your hard drive) and remote storage (the Web server). Make sure 
that you're not transferring files from the Web server to your local drive 
(erasing your files in the process), when you want to transfer them from 
the local systemto the remote system.

To upload files to your Web site:

1 If you're not logged onto your Web server, do so now. The FTP 
Site Window appears. If you don't know how to log onto your 
Web server, see “Connecting to your Web server” on page 8-3.

2 If necessary, navigate to the directory where you store your Web 
files. This is the location to which you'll upload your Web files.

3 Select the file(s) you want to publish.

4 Click the Publish button. The Open dialog box displays.

5 Select the file(s) you want to publish, then click Open.

Note: You may find it more convenient to upload an entire folder, instead 
of multiple files — Visual Page supports folder uploading, using the same 
steps as above.
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Downloading files from your Web server
You may occasionally need to download a file or files from your Web site 
— for example, if you are archiving an older version of your site, or have 
accidentally deleted a file off your local hard drive.

To download files from a Web server:

1 If you're not logged onto your Web server, do so now. The FTP 
Site Window appears. If you don't know how to log onto your 
Web server, see “Connecting to your Web server” on page 8-3.

2 If necessary, navigate to the directory where you store your Web 
files. This is the location from where you'll download your Web 
files.

3 Select the name of the file(s) that you want to download. If you 
are selecting multiple files, be sure to select them in the file list on 
the right-hand site of the FTP Site Window.

4 Click the Download button at the top of the window. The 
navigation dialog box for your local hard drive displays.

5 Navigate to the folder where you want to store the file(s) to be 
downloaded.

6 Click Save. The file(s) download.

Note: You may find it more convenient to download an entire folder, 
instead of multiple files — Visual Page supports folder downloading, using 
the same steps as above.

Disconnecting from the Web
Once you finish uploading or downloading your files, you may want to 
disconnect from your Web server, then from the Internet.

To disconnect from your Web server:

• Close the FTP window by clicking the close window icon, or by 
selecting Close from the File menu.
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To disconnect from the Internet:

There are two ways to disconnect from the Internet, depending on the type 
of Internet connection that you have:

n If you are using a non-network Internet account to connect 
(such as SLIP or PPP), use your Internet dial-up software to 
disconnect. See the user's guide for your dial-up software for 
further details.

n If you access the Internet through an internal network (such as 
your companies' Intranet), do nothing — your connection is 
handled by your System Administrator.

Maintaining your Web site
Visual Page includes several features you can use to maintain the files on 
your Web site and to perform other related tasks. 

Deleting remote files

Visual Page supports the deletion of files directly off of your Web server, 
without the use of third party FTP software. 

To delete a file from your Web server:

1 If you're not logged onto your Web server, do so now. The FTP 
Site Window appears. If you don't know how to log onto your 
Web server, see “Connecting to your Web server” on page 8-3.

2 Select the name of the file you want to delete.

3 Click the Delete button. 

Note: You may find it more convenient to delete an entire folder, instead of 
multiple files — Visual Page supports deletion of folders, using the same 
steps as above. Be sure that you want to delete all of the files in the folder 
before you do this!

Renaming remote files

Visual Page supports the renaming of files directly on your Web server. 
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To rename a file on your Web server:

1 If you're not logged onto your Web server, do so now. The FTP 
Site Window appears. If you don't know how to log onto your 
Web server, see “Connecting to your Web server” on page 8-3.

2 Select the name of the file you want to rename.

3 Click the Rename button.

4 Type the new name in the New Name field.

Note: Visual Page doesn’t support the renaming of remote folders.

Creating a remote folder

Visual Page supports the creation of folders directly on your Web server. 

To create a new folder on your Web server:

1 If you're not logged onto your Web server, do so now. The FTP 
Site Window appears. If you don't know how to log onto your 
Web server, see “Connecting to your Web server” on page 8-3.

2 Press the New Folder button.

3 Type in the new name in the New Remote Folder field.

4 Click OK.

The new folder is created within the folder displayed at the top of the Web 
server window.

Moving files

Visual Page supports the moving of files and folders on your Web servers. 
If you do this, be aware that your links may not work after you’ve moved 
the files to their new location.

To help avoid breaking links when you move only one file or set of files, 
but not all the files on a Web site, you can use the Base URL option. The 
Base URL allows you to have moved folders still link correctly to other files 
that remain in the original location.

For example, say you want to move one file into a different directory on 
the Web server, or a new site entirely. You still want the file’s links, which 
point to other files on your Web site, to still work. You can set the Base 
URL option to retain the links in the file after you’ve moved it.
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To set the Base URL for a Web page:

1 Make sure that the desired Web page is open and active, and that 
you’re also in Edit mode. To go to Edit mode, click the Edit Page 
toolbar button.

2 From the Edit menu, select Properties > Page. You can also click 
the Page Properties toolbar button.

3 In the Base URL area, type the URL for the former directory 
location of your Web page. For example,

http://cafe.symantec.com/home/.

4 Click OK. 

The Base URL is now set for your Web page.

Calculating file transmission times

Visual Page provides tools for determining the amount of time that it takes 
for a file to transfer, given the file's content and the connection speed.

To determine the download time for a file:

1 Open the file for which you want to determine the transmission 
time for.

2 From the File menu, choose Download Statistics. The Download 
Statistics window displays.

The Download Statistics window consists of the following elements:

n The Total Document bar displays the transmission time for the 
file in the active window, at the baud rate indicated in the 
Modem Speed pop-up menu.
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n The Selected Object bar displays the transmission time for the 
selected object (such as a GIF image), at the baud rate indicated 
in the Modem Speed pop-up menu. If no object is selected, the 
displayed transmission time is set to 0 seconds.

n The Selected Frame bar displays the transmission time for the 
selected frame set, at the baud rate indicated in the Modem 
Speed pop-up menu. If no frame is selected, this bar doesn’t 
display.

n The calculated transmission times are displayed in the right-
hand side of the window.

3 To calculate a time for a different baud rate, select the new rate 
from the Modem Speed pop-up menu. The recalculated time 
displays in the right-hand side of the window.

Mapping folders

Note: If you are not very familiar with the differences between remote and 
local file mapping, do not use this feature. Misuse of this feature may result 
in some or all of your links breaking.

Visual Page lets you map local folders to their remote counterparts. This 
feature allows you to replace all references to a local folder on your hard 
drive with a remote (Web server-based) folder or a URL. This feature can 
save you hours of changing references to local folders to their remote 
folder or URL counterparts. For example, if you have eight Web sites, all of 
which use the remote URL http://www.mysite.com/graphics to 
store graphics, you can map the URL to the respective graphics folders for 
your local sites, without having to change the links to the URL for all eight 
Web sites.

Be sure to map your folders between your local and remote sites before 
you start creating pages — this will prevent you from having to remap the 
folders if you decide to change the folder's names midway through the 
process.

To map your local and remote folders:

1 Choose Preferences from the Edit menu. The Preferences dialog 
box displays.
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2 Select the Folder Mappings tab, as shown below.

3 Place the cursor in the first empty cell of the Remote column.

4 Type in the full pathname or URL of the remote folder.

5 Press Tab.

6 Type in the name of the local folder you want to map to the 
remote folder or URL.

You can also select a local folder by clicking the Local Folder button, 
navigating to the folder you want to map, then pressing the button at 
the bottom of the Select Folder dialog box.

7 Repeat steps 3-6 for any additional folders that you want to map.

8 If you want to override the specified local and remote folders, 
click Revert; otherwise, click OK.

What’s next

A glossary of commonly used terms follows this chapter. 

Good luck with your Web projects, and enjoy using Visual Page!
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anchor

A type of link, used to mark specific locations within a Web page.

applet

A Java program that is designed to run only on a Web page.

base URL

The base URL for a Web page sets the URL upon which all links in the 
Web page are based.

cell

A cell is a separate entry area within a table. 

CGI

An acronym for Common Gateway Interface. CGI is the protocol that 
handles the information that a user enters into a form.

client

The user of a network; alternately, a local application that connects to a 
remote server.

edit mode

The edit mode is used to create and modify Web-based content. 
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forms

Forms let users pass information (such as their name and address) from 
their browser to a Web server. Forms commonly interface with Common 
Gateway Interface (CGI) applications.

frame

The element within a frame set that contains a HTML file.

frame set

A type of Web page, consisting of two or more independent sections 
(frames) that each display a HTML file. 

FTP

An acronym for File Transfer Protocol. The File Transfer Protocol is the 
common command set used to upload and download files from Web sites. 
Visual Page uses FTP extensively as part of its set of Web publishing 
features.

GIF

An acronym for Graphic Interchange Format. Developed by CompuServe, 
the Graphic Interchange Format is a common cross-platform, WWW format 
for graphics. Another common WWW graphic format is the JPEG format.

HTML

An acronym for HyperText Markup Language. It is used to “markup” or 
identify which parts of a .html or .htm text file to display in which 
format.

hypertext

Computer documents that contain links embedded in text or graphics. 
Hypertext links display related information when you click on them.
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image map

A graphic with linkable regions within it. There are two types of image 
maps: client side, which contain their coordinate information within the 
graphic file, and server side, which contains its coordinate information in a 
separate .map file on the server.

insertion point

Any text you enter appears at the insertion point, which is indicated by 
the text cursor. 

interlaced images

Interlaced images download as first a general outline of the image, and 
then as more image data is received by the browser, the details of the 
image come into view. 

Internet

The largest computer network in the world. Originally designed for military 
use, the Internet expanded into academic usage, and then into the public 
arena.

Intranet

A subsection of the Internet, contained within a corporate network.

Java

An object-oriented programming language developed by Sun 
Microsystems. Java is device independent, allowing compiled Java 
programs and applets to run on any computer.

JavaScript

A scripting language developed by Netscape Communications.
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JPEG

A acronym for Joint Photographic Experts Group, the creators of the JPEG 
file format. The JPEG format was developed for high-quality photographs 
and supports 24-bit images. Another common WWW graphic format is the 
GIF format.

link

Web page-based text or graphics that respond to a mouse click by 
displaying the media that they’re connected to, such as a Web page. 

local Web site

A collection of Web pages that are installed on your local computer.

Local Site window

The Visual Page Local Site window provides easy access to all of the files 
that will make up your Web site.

main editing window

The main editing window serves as the visual editor for Visual Page. This is 
where you’ll do most of your Web page formatting and editing

network protocol

Aset of predefined commands to process information over a computer 
network.

plugins

An accessory to a Web browser, commonly used to extend the browser’s 
feature range. 

preview mode

The preview mode is a way to view documents as they appear in a user’s 
browser.
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remote Web site

The version of your site that is accessible via the Web is called your 
remote Web site.

server

A computer that is configured (via software and hardware) for the storage 
and handling of files.

source editor

The source editor is used to edit the HTML source code of a Web page.

table

A method of presenting information in a uniform format (rows and 
columns). 

target

The frame or Web page window that a linked file displays in. 

text cursor

The text cursor appears as blinking vertical line, and indicates the 
insertion point for any text you enter.

URL

An acronym for Uniform Resource Locator. A specific address used by Web 
browsing software to locate and access information on the Web.

Web browser

The local application you use to connect to a Web server. It interprets and 
displays HTML-encoded documents (Web pages) graphically.
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Web page

A text document which is encoded in HTML, displayed by a browser 
application, and accessible from remote sites via the Web.

Web server

A type of server dedicated to storing, transmitting, and receiving Web 
pages and Web-related files, such as GIF and JPEG graphics.

Web site

A collection of files that are linked to a central Web page, made available 
via the Web.

World Wide Web

The part of the Internet that contains Web pages. The World Wide Web is 
commonly referred to either by its acronym “WWW”, or simply as the Web.
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A
anchors, 1-9, 1-11–1-12, 4-4–4-6, 4-9–4-10

definition, 1-11, G-1
displaying, 4-4–4-6
testing and fixing, 4-9–4-10

applets, 1-16, 7-4–7-7
definition, 1-16, G-1
inserting, 7-4
preferences, 7-5–7-7

attributes. See preferences

C
CGI, 1-16, 7-10–7-11

definition, 1-16, G-1
characters

changing font size of, 3-10
formatting, 3-3, 3-8–3-9
styles, 3-8–3-9

client, G-1
Common Gateway Interface. See CGI

D
documentation

online help, 1-4
Visual Page tour, 1-4

E
edit mode, 2-17
editing area, 2-5

F
File Transfer Protocol. See FTP
folder mapping, 2-8, 8-10–8-11
font size, 3-10
forms, 1-16, 7-9–7-12

definition, 1-16
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Forms Palette, 7-10
inserting form elements, 7-10
inserting multiple, 7-11–7-12

frame layouts, 1-13–1-14, 6-1–6-5
creating, 6-2–6-3
definition, 1-13, G-2
No Frames window, 6-10–6-11
saving, 6-3

frames, 1-13–1-14, 6-1–6-14
changing Web page in, 6-6
definition, 1-13, G-2
displaying Web page in own window, 6-6–6-7
preferences, 6-7–6-9
removing, 6-10
resizing, 6-9–6-10
saving, 6-4–6-5
setting target for, 6-11–6-14
splitting, 6-10

FTP, 1-8–1-9, 8-2–8-4
definition, 1-8, G-2

G
GIF, 5-1, G-2
graphics, 5-1–5-17

aligning, 5-4
copying and pasting, 5-3–5-4
file types, 5-1
flowing text around, 5-4–5-5
image maps, 1-15, 5-13–5-17
inserting, 5-2–5-4
preferences, 2-8, 5-4–5-7
tiled backgrounds, 5-9–5-11
transparent, 5-7–5-8

H
home page, 1-6
HTML, 1-1, 1-7–1-8, 3-11–3-12, G-2
hypertext, G-2

definition, 1-9
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I
image map

definition, G-3
image maps, 1-15, 5-13–5-17
Internet, G-3
Intranet, G-3

J
Java, 1-16

applets, 7-4–7-7
console, 7-7
definition, G-3

JavaScript, 1-16, 7-7–7-9
adding to a Web page, 7-8
calling a JavaScript file, 7-8–7-9
creating a JavaScript file, 7-8
definition, 1-16, G-3

JPEG, 5-1, G-4

L
launching Visual Page, 2-1
line breaks, 3-11
lines, 5-12–5-13
Link To field, 2-5, 4-3
links, 1-10–1-11, 4-1–4-3, 4-6–4-10

coloring, 4-6
creating, 4-1–4-3
definition, 1-10, G-4
email address in, 4-9
setting target for, 6-11–6-14
testing and fixing, 4-9–4-10

lists
bullet, 3-6
numbered, 3-6–3-7

local Web site, 2-12
definition, G-4
mapping to remote site, 8-10–8-11

M
main editing window, 2-2–2-5
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N
Network

preferences, 2-8, 8-1–8-4

P
paragraph breaks, 3-11
paragraph styles, 3-3–3-7
paragraphs

aligning, 3-8
formatting, 3-3–3-8, 3-11–3-12
indenting, 3-8

plugins, 1-15, 7-1–7-4
definition, 1-15, G-4
inserting, 7-1
preferences, 7-2–7-4

preferences
applets, 7-5–7-7
folder mapping, 8-10–8-11
frames, 6-7–6-9
global, 2-6–2-8
graphics, 5-4–5-7
lines, 5-12–5-13
Network, 2-8, 8-1–8-4
plugins, 7-2–7-4
setting, 2-5–2-11
tables, 6-21–6-25
Visual Page, 2-6–2-8
Web pages, 2-9–2-11
Web servers, 2-8, 8-1–8-4

preview mode, 2-17
printing, 2-19–2-20
properties. See preferences

R
remote Web site, 2-13

mapping local sites to, 8-10–8-11
rules. See lines

S
saving, 2-18–2-19
server, G-5
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settings. See preferences
Site Window, 2-12–2-13, 4-2
source editor, 2-17–2-18
starting Visual Page, 2-1
styles

Address, 3-5–3-6
applying, 3-3–3-7
Bullet, 3-6
Description, 3-7
Headers, 3-4
Normal, 3-4
Ordered, 3-6–3-7
Preformatted, 3-5
Term, 3-7

symbols, 3-13
system requirements, 1-3

T
tables, 1-14–1-15, 6-14–6-25

cells, 6-14, 6-21, 6-23–6-25
coloring, 6-19–6-21
creating, 6-14–6-15
definition, 1-14
deleting columns, 6-17
deleting rows, 6-17
editing, 6-15–6-19
editing multiple cells, 6-16
inserting columns, 6-17
inserting rows, 6-17
preferences, 6-21–6-25
resizing, 6-19
spanning rows and columns, 6-18

tags, 1-7–1-8
target, 6-11

definition, G-5
text, 3-1–3-13

coloring, 2-9, 3-10–3-11, 6-19–6-21
copying and pasting, 3-2–3-3
dragging and dropping, 3-2
flowing around graphics, 5-4–5-5
inserting, 3-1–3-3

tiled backgrounds, 5-9–5-11
toolbar, 2-3–2-4
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buttons, 2-4

U
Uniform Resource Locator. See URL
URL, 1-9–1-10

definition, 1-9, G-5

V
Visual Cafe, 7-7
Visual Page

interface components, 2-2–2-5
languages supported by, 2-11
main editing window, 2-1
preferences, 2-6–2-8
starting, 2-1
templates included with, 2-16

W
Web browser, 1-7

definition, G-5
Web pages

creating, 2-13–2-17
definition, 1-5, G-6
download times for, 8-9–8-10
opening, 2-1
preferences, 2-9–2-11
printing, 2-19–2-20
saving, 2-18–2-19
templates, 2-16
testing and fixing links in, 4-9–4-10

Web programming, 1-15–1-16, 7-4–7-12
Web publishing, 1-5–1-9, 8-4–8-5
Web servers, 8-1–8-11

and CGI, 1-16
connecting to, 8-3–8-4
creating folders on, 8-8
default settings, 8-1–8-2
definition, 1-8, G-6
deleting files from, 8-7
downloading files from, 8-6
mapping folders on, 8-10–8-11
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preferences, 2-8, 8-1–8-2
renaming files on, 8-7–8-8
uploading files to, 8-4–8-5

Web sites
definition, 1-6, G-6
maintaining, 8-7–8-11
managing, 8-1–8-11
setting up, 2-12–2-13
Symantec, 1-5–1-8
Symantec Cafe, 1-6–1-7

Web, the. See World Wide Web
World Wide Web, 1-5

definition, G-6
disconnecting from, 8-6–8-7

WWW. See World Wide Web
Index-7



- Index
Index-8


	Symantec Visual Page User’s Guide
	Overview
	About Visual Page
	Features
	Accessible and powerful feature set
	Extensive HTML authoring tools
	State-of-the-art media support
	Extensive template and sample set
	Site management tools
	Updating Visual Page
	System requirements
	Visual Page’s documentation
	User’s Guide
	Visual Page Getting Started Guide
	Online help


	Web basics
	Publishing on the Web
	What are Web pages?
	What is a Web site?
	What are HTML tags?
	What is FTP?

	Hypertext and URLs
	What are URLs?
	What are links?
	What are anchors?

	Designing on the Web
	What are frame sets?
	What are tables?
	What are image maps?
	What are plugins?

	Programming on the Web
	What are applets?
	What is JavaScript?
	What are forms?

	What’s next


	Creating Web pages
	Launching Visual Page
	Opening Web files

	The Visual Page interface
	Setting preferences
	Setting the global preferences
	Setting Web page preferences

	Setting up your local Web site
	Starting a Web page
	Starting a Web page from scratch
	Starting a Web page from an existing page
	From your computer
	From the Web

	Starting a Web page from a template

	Previewing your work
	Viewing the HTML code
	Saving a Web page
	Printing a Web page
	What’s next


	Working with text
	Inserting text into a Web page
	Typing text into a Web page
	Dragging and dropping text into a Web page
	Copying and pasting text into a Web page

	Formatting text
	Formatting paragraphs
	Normal
	Headers
	Preformatted
	Address format
	Bullet lists
	Ordered lists
	Term and description lists
	Aligning paragraphs
	Indenting paragraphs

	Formatting characters
	Changing the font size

	Coloring text

	Creating paragraphs and line breaks
	Adding additional HTML styles
	Adding HTML tags to a source file
	Adding special symbols and characters
	What’s next


	Adding links and anchors
	Inserting links
	Using the Local Site window to insert a link
	Using the Link To field
	Using the desktop to insert a link
	Using the Hyperlink button

	Inserting and displaying anchors
	Inserting anchors
	Displaying anchors

	Coloring links
	Setting the color for normal links
	Setting the color for active links
	Setting the color for visited links

	Creating email address links
	Testing and fixing links and anchors
	Testing links and anchors
	Locating and fixing broken link errors
	What’s next


	Using graphics and image maps
	Supported graphic file types
	GIF
	JPEG

	Inserting a graphic
	Using the Local Site window to insert a graphic
	Using the toolbar to insert a graphic
	Using the Insert menu to insert a graphic
	Copying and pasting a graphic

	Aligning graphics
	Flowing text around graphics
	Setting a graphic's attributes
	Creating transparent graphics
	Creating interlaced images
	Creating tiled backgrounds
	Creating lines
	Inserting a line
	Setting a line's attributes

	Creating and editing image maps
	Creating client-side image maps
	Creating server-side image maps
	What’s next


	Creating frame sets and tables
	Creating frame sets
	Changing a frame's Web page
	Displaying a frame-based Web page in its own windo...
	Setting a frame's attributes
	Modifying frames
	Changing a frame's size
	Removing a frame
	Splitting frames

	Using the No Frames window
	Setting the frame target

	Creating tables
	Inserting tables
	Editing tables
	Selecting and editing multiple cells
	Inserting rows and columns
	Deleting rows and columns
	Spanning rows and columns
	Resizing rows and columns
	Resizing tables

	Adding color to tables
	Setting table attributes
	Setting cell attributes
	What’s next


	Advanced features
	Inserting plugins and applets
	Inserting plugins
	Setting plugin attributes
	Inserting applets
	Setting applet attributes
	Visual Page's Java console
	Visual Page and Visual Cafe

	Using JavaScript
	Adding JavaScript to a Web page
	Accessing a stand-alone JavaScript file

	Creating forms
	Adding form elements to a Web page
	Using CGI
	Inserting multiple forms
	What’s next


	Managing and maintaining your Web site
	Setting up your network connection
	Connecting to your Web server
	Uploading files to your Web server
	Downloading files from your Web server
	Disconnecting from the Web
	Maintaining your Web site
	Deleting remote files
	Renaming remote files
	Creating a remote folder
	Moving files
	Calculating file transmission times
	Mapping folders
	What’s next


	Glossary
	anchor
	applet
	base URL
	cell
	CGI
	client
	edit mode
	forms
	frame
	frame set
	FTP
	GIF
	HTML
	hypertext
	image map
	insertion point
	interlaced images
	Internet
	Intranet
	Java
	JavaScript
	JPEG
	link
	local Web site
	Local Site window
	main editing window
	network protocol
	plugins
	preview mode
	remote Web site
	server
	source editor
	table
	target
	text cursor
	URL
	Web browser
	Web page
	Web server
	Web site
	World Wide Web

	Index

